aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux_2.6.27.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/linux_2.6.27.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/linux_2.6.27.bb')
-rw-r--r--recipes/linux/linux_2.6.27.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/recipes/linux/linux_2.6.27.bb b/recipes/linux/linux_2.6.27.bb
new file mode 100644
index 0000000000..0b219ec705
--- /dev/null
+++ b/recipes/linux/linux_2.6.27.bb
@@ -0,0 +1,53 @@
+require linux.inc
+
+PR = "r6"
+
+# Mark archs/machines that this kernel supports
+DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_boc01 = "1"
+DEFAULT_PREFERENCE_progear = "1"
+DEFAULT_PREFERENCE_simpad = "-1"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
+ file://defconfig "
+
+SRC_URI_append_boc01 = "\
+ file://boc01.dts \
+ file://001-090114-sqn11x0-usb-hack.patch;patch=1 \
+ file://004-081205-usb.patch;patch=1 \
+ file://005-090217-isl12024.patch;patch=1 \
+ file://007-081217-lm73.patch;patch=1 \
+ file://008-081208-spi.patch;patch=1 \
+ file://010-090112-mii.patch;patch=1 \
+ file://011-090115-gpio.patch;patch=1 \
+ file://012-090219-capsense.patch;patch=1 \
+ file://013-090209-lcd.patch;patch=1 \
+ file://014-090209-pm-wakeup.patch;patch=1 \
+ "
+
+SRC_URI_append_progear = "file://progear-bl.patch;patch=1\
+ file://progear-ac2.patch;patch=1"
+
+SRC_URI_append_simpad = "\
+ file://linux-2.6.27-SIMpad-GPIO-MMC-mod.patch;patch=1 \
+ file://linux-2.6.27-SIMpad-battery-old-way-but-also-with-sysfs.patch;patch=1 \
+ file://linux-2.6.27-SIMpad-cs3-simpad.patch;patch=1 \
+ file://linux-2.6.27-SIMpad-mq200.patch;patch=1 \
+ file://linux-2.6.27-SIMpad-pcmcia.patch;patch=1 \
+ file://linux-2.6.27-SIMpad-serial-gpio_keys-and-cs3-ro.patch.v2;patch=1 \
+ file://linux-2.6.27-SIMpad-ucb1x00-switches.patch;patch=1 \
+ file://linux-2.6.27-SIMpad-ucb1x00-ts-supend-and-accuracy.patch;patch=1 \
+ file://linux-2.6.24-SIMpad-hostap_cs-shared-irq.patch;patch=1 \
+ file://linux-2.6.24-SIMpad-orinoco_cs-shared-irq.patch;patch=1 \
+ file://linux-2.6.24-SIMpad-rtc-sa1100.patch;patch=1 \
+ file://connectplus-remove-ide-HACK.patch;patch=1 \
+ "
+
+# see http://bugzilla.kernel.org/show_bug.cgi?id=11143
+do_stage_append() {
+ if [ -f arch/${ARCH}/lib/crtsavres.o ]; then
+ mkdir -p ${STAGING_KERNEL_DIR}/arch/${ARCH}/lib
+ cp -a arch/${ARCH}/lib/crtsavres.o ${STAGING_KERNEL_DIR}/arch/${ARCH}/lib/
+ fi
+}
+