aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux_2.6.26.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/linux_2.6.26.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/linux_2.6.26.bb')
-rw-r--r--recipes/linux/linux_2.6.26.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/recipes/linux/linux_2.6.26.bb b/recipes/linux/linux_2.6.26.bb
new file mode 100644
index 0000000000..ff4ced7fec
--- /dev/null
+++ b/recipes/linux/linux_2.6.26.bb
@@ -0,0 +1,44 @@
+require linux.inc
+
+PR = "r8"
+
+# Mark archs/machines that this kernel supports
+DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_boc01 = "1"
+DEFAULT_PREFERENCE_mpc8313e-rdb = "1"
+DEFAULT_PREFERENCE_canyonlands = "1"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.26.tar.bz2 \
+ file://defconfig"
+
+SRC_URI_append_boc01 = "\
+ file://boc01.dts \
+ file://fsl-elbc-nand-backport.patch;patch=1 \
+ file://002-081105-headers.patch;patch=1 \
+ file://004-081105-usb.patch;patch=1 \
+ file://005-081217-isl12024.patch;patch=1 \
+ file://006-081216-at24c32.patch;patch=1 \
+ file://007-081216-lm73.patch;patch=1 \
+ file://008-081127-spi.patch;patch=1 \
+ file://010-081105-mii.patch;patch=1 \
+ file://011-081202-gpio.patch;patch=1 \
+ file://012-081222-cy3218-btns.patch;patch=1 \
+ file://013-081212-lcd.patch;patch=1 \
+ "
+
+SRC_URI_append_mpc8313e-rdb = "\
+ file://cdc-ether-hack.patch;patch=1 \
+ file://fsl-elbc-nand-backport.patch;patch=1 \
+ file://mpc8313e-rdb-leds.patch;patch=1 \
+ file://mpc8313e-rdb-cardbus.patch;patch=1 \
+ file://mpc8313e-rdb-eth-fixed.patch;patch=1 \
+ "
+
+# see http://bugzilla.kernel.org/show_bug.cgi?id=11143
+do_stage_append() {
+ if [ -f arch/${ARCH}/lib/crtsavres.o ]; then
+ mkdir -p ${STAGING_KERNEL_DIR}/arch/${ARCH}/lib
+ cp -a arch/${ARCH}/lib/crtsavres.o ${STAGING_KERNEL_DIR}/arch/${ARCH}/lib/
+ fi
+}
+