aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-openmoko-2.6.30.4/400-ledtrig_morse.patch
diff options
context:
space:
mode:
authorAngus Ainslie <nytowl@openmoko.org>2009-08-21 23:03:24 -0600
committerAngus Ainslie <nytowl@openmoko.org>2009-08-21 23:03:24 -0600
commit79e953889744b03f7e458e36e87701c1f9375f4b (patch)
tree8ce7dc618502a9171425a3a3437f0ea9c02f0076 /recipes/linux/linux-openmoko-2.6.30.4/400-ledtrig_morse.patch
parentd1c0d0197307dc96fb5398cc82e3e3a53d040697 (diff)
downloadopenembedded-79e953889744b03f7e458e36e87701c1f9375f4b.tar.gz
linux-openmoko : add more openwrt patches to fix mmc issues and snd_soc oops
Diffstat (limited to 'recipes/linux/linux-openmoko-2.6.30.4/400-ledtrig_morse.patch')
-rw-r--r--recipes/linux/linux-openmoko-2.6.30.4/400-ledtrig_morse.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/linux/linux-openmoko-2.6.30.4/400-ledtrig_morse.patch b/recipes/linux/linux-openmoko-2.6.30.4/400-ledtrig_morse.patch
new file mode 100644
index 0000000000..2754ed6d7e
--- /dev/null
+++ b/recipes/linux/linux-openmoko-2.6.30.4/400-ledtrig_morse.patch
@@ -0,0 +1,18 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -295,4 +295,8 @@ config LEDS_TRIGGER_DEFAULT_ON
+ comment "iptables trigger is under Netfilter config (LED target)"
+ depends on LEDS_TRIGGERS
+
++config LEDS_TRIGGER_MORSE
++ tristate "LED Morse Trigger"
++ depends on LEDS_TRIGGERS
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -38,3 +38,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) +=
+ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) += ledtrig-backlight.o
+ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o
+ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
++obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o