aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-jlime-jornada7xx_2.6.32+git.bb
diff options
context:
space:
mode:
authorKristoffer Ericson <kristoffer.ericson@gmail.com>2010-03-09 22:44:48 +0100
committerKristoffer Ericson <kristoffer.ericson@gmail.com>2010-03-09 22:44:48 +0100
commit1fb6cc37b0e68ef0fcfcd4f12ac0d1bec034f894 (patch)
tree833b47e1892e75b2078a96b1db2d0be6cec4e7aa /recipes/linux/linux-jlime-jornada7xx_2.6.32+git.bb
parent0135ae31d148e2175a0d7d9a92180d70b4a8e0b5 (diff)
downloadopenembedded-1fb6cc37b0e68ef0fcfcd4f12ac0d1bec034f894.tar.gz
linux/linux/linux-jlime-jornada7xx_2.6.32+git.bb:
* Add newest HP Jornada 700-series kernel recipe. Signed-off-by: Filip Zyzniewski <filip.zyzniewski@gmail.com> Signed-off-by: Kristoffer Ericson <kristoffer.ericson@gmail.com>
Diffstat (limited to 'recipes/linux/linux-jlime-jornada7xx_2.6.32+git.bb')
-rw-r--r--recipes/linux/linux-jlime-jornada7xx_2.6.32+git.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes/linux/linux-jlime-jornada7xx_2.6.32+git.bb b/recipes/linux/linux-jlime-jornada7xx_2.6.32+git.bb
new file mode 100644
index 0000000000..d8d09ac9c1
--- /dev/null
+++ b/recipes/linux/linux-jlime-jornada7xx_2.6.32+git.bb
@@ -0,0 +1,35 @@
+SECTION = "kernel"
+DESCRIPTION = "JLime Linux kernel for Arm based Jornada 7xx"
+LICENSE = "GPL"
+PR = "r0"
+
+COMPATIBLE_HOST = "arm.*-linux"
+COMPATIBLE_MACHINE = "jornada7xx"
+
+SRC_URI = "file://defconf_jlime"
+
+S = "${WORKDIR}/linux-hpc"
+
+inherit kernel
+
+ARCH = "arm"
+
+FILES_kernel-image = "/boot/${KERNEL_IMAGETYPE}*"
+
+do_fetch () {
+ cd ${WORKDIR}
+ [ -d linux-hpc ] && {
+ cd linux-hpc
+ git pull
+ } || {
+ git clone git://git.kernel.org/pub/scm/linux/kernel/git/kristoffer/linux-hpc.git
+ cd linux-hpc
+ # written individual do_fetch function because I don't know how to do this in SRC_URI:
+ git-checkout --track -b v2.6.32-hpc origin/v2.6.32-hpc
+ git-checkout v2.6.32-hpc
+ }
+}
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconf_jlime ${S}/.config
+}