summaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-ea3250_2.6.27.8.bb
diff options
context:
space:
mode:
authorRuud Althuizen <ruud@il.fontys.nl>2010-02-01 13:36:24 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-02-12 22:43:26 +0100
commitfb1e00bdcdce8dfc516ab7aba3664df15b124159 (patch)
tree4c22d99d2b419b1e85046d6b6ebcd063648796d1 /recipes/linux/linux-ea3250_2.6.27.8.bb
parent41f1d9de92fa5857c886cab5fa0fcf0835c1a29c (diff)
downloadopenembedded-fb1e00bdcdce8dfc516ab7aba3664df15b124159.tar.gz
linux-ea3250: New recipe
This is a kernel recipe for the LPC32XX (LPC3250) based Embedded Artists development board. It uses public patches provided by NXP and Embedded Artists. The other two patches provide drivers for the PWM capabilities and fix one NXP patch. It can be generalized for use with the PHYTEC LPC3250 development board. Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/linux-ea3250_2.6.27.8.bb')
-rw-r--r--recipes/linux/linux-ea3250_2.6.27.8.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes/linux/linux-ea3250_2.6.27.8.bb b/recipes/linux/linux-ea3250_2.6.27.8.bb
new file mode 100644
index 0000000000..37c152da17
--- /dev/null
+++ b/recipes/linux/linux-ea3250_2.6.27.8.bb
@@ -0,0 +1,46 @@
+SECTION = "kernel"
+DESCRIPTION = "Linux kernel for the EmbeddedArtists LPC3250 development board"
+HOMEPAGE = "http://embeddedartists.com"
+# DEPENDS = ""
+LICENSE = "GPL"
+PR = "r0"
+
+# Location of the base kernel and NXP's patches
+
+# It is advisable to mirror the patches listed below, as there is no certainty
+# that they will stay there indefinitely.
+# - Joost
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.27.8.tar.bz2 \
+ http://bitshrine.org/gpp/kernel-arm-2.6.27.8-lpc32xx.patch;patch=1 \
+ http://bitshrine.org/gpp/kernel-arm-2.6.27.8-update1.patch;patch=1 \
+ http://bitshrine.org/gpp/kernel-arm-2.6.27.8-lpc32xx_update2.patch;patch=1 \
+ http://bitshrine.org/gpp/kernel-arm-2.6.27.8-lpc32xx_update3.patch;patch=1 \
+ http://bitshrine.org/gpp/kernel-arm-2.6.27.8-lpc32xx_armtskit_update2.patch;patch=1 \
+ http://bitshrine.org/gpp/kernel-arm-2.6.27.8-lpc32xx_ea3250.patch;patch=1 \
+ http://bitshrine.org/gpp/kernel-arm-2.6.27.8-lpc32xx_update4.patch;patch=1 \
+ http://bitshrine.org/gpp/kernel-arm-2.6.27.8-lpc32xx_update5.patch;patch=1 \
+ file://kernel-arm-2.6.27.8-lpc32xx_update5_fix.patch;patch=1 \
+ file://lpc32xx-spwm.patch;patch=1 \
+ file://defconfig"
+
+# Source directory
+S = "${WORKDIR}/linux-${PV}"
+
+# Which machines are supported by this kernel
+COMPATIBLE_HOST = 'arm.*-linux'
+
+# Kernel object suffix (should be .o)
+KERNEL_OBJECT_SUFFIX = ".o"
+
+# Inherit the class that actually builds the kernel
+inherit kernel
+
+# Kernel command line
+# XXX
+CMDLINE = "root=/dev/mmcblk0p2 console=ttyS0,115200"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+}
+
+COMPATIBLE_MACHINE = "ea3250"