summaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-2.6.31/pcm043/0009-MX31-Fix-spi-clock-names.patch
diff options
context:
space:
mode:
authorJan Kobler <eng1@koblersystems.de>2011-03-01 14:01:38 +0100
committerTom Rini <tom_rini@mentor.com>2011-03-01 11:26:09 -0700
commit1840fd720b423ed4245a4fdb511170ae33dfde80 (patch)
tree92ec149ed37bf1981debf236649546c96c1024e4 /recipes/linux/linux-2.6.31/pcm043/0009-MX31-Fix-spi-clock-names.patch
parentaffc152bd4df73fd3892eb09cab0a331fd282866 (diff)
downloadopenembedded-1840fd720b423ed4245a4fdb511170ae33dfde80.tar.gz
linux-2.6.31 config and patch files for pcm043
These config and patch files are from the Phytec Linux BSP for phyCORE-i.MX35 PD10.1.1. They were taken from the archive ftp://ftp.phytec.de/pub/Products/phyCORE-iMX350/Linux/PD10.1.1/OSELAS.BSP-Phytec-phyCORE-i.MX35-PD10.1.1.tar.gz The patch files are from the folder in this archive OSELAS.BSP-Phytec-phyCORE-i.MX35-PD10.1.1/configs/phyCORE-i.MX35-2010.08.0/patches/linux-2.6.31.6/generic The patch files have been shipped for linux-2.6.31.6 and are used here on linux-2.6.31.12. Because it seems to work, pcm043 is added to linux-2.6.31.bb. The sequence of the patches for pcm043 in linux-2.6.31.bb is derived from the file OSELAS.BSP-Phytec-phyCORE-i.MX35-PD10.1.1/configs/phyCORE-i.MX35-2010.08.0/patches/linux-2.6.31.6/generic/series The defconfig file is the file OSELAS.BSP-Phytec-phyCORE-i.MX35-PD10.1.1/configs/phyCORE-i.MX35-2010.08.0/kernelconfig These patch files from the folder OSELAS.BSP-Phytec-phyCORE-i.MX35-PD10.1.1/configs/phyCORE-i.MX35-2010.08.0/patches/linux-2.6.31.6/generic are NOT used: 0063-add-generic-platform-bus-based-sja1000-driver.patch 0076-mx3fb-pretty-printing-update.patch 0078-sja1000-driver-Fix-net-device-stats.patch patch-2.6.31.6-rt19.gz because they are not referenced by the file OSELAS.BSP-Phytec-phyCORE-i.MX35-PD10.1.1/configs/phyCORE-i.MX35-2010.08.0/patches/linux-2.6.31.6/generic/series Signed-off-by: Jan Kobler <eng1@koblersystems.de> Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/linux/linux-2.6.31/pcm043/0009-MX31-Fix-spi-clock-names.patch')
-rw-r--r--recipes/linux/linux-2.6.31/pcm043/0009-MX31-Fix-spi-clock-names.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/linux/linux-2.6.31/pcm043/0009-MX31-Fix-spi-clock-names.patch b/recipes/linux/linux-2.6.31/pcm043/0009-MX31-Fix-spi-clock-names.patch
new file mode 100644
index 0000000000..f59d12723d
--- /dev/null
+++ b/recipes/linux/linux-2.6.31/pcm043/0009-MX31-Fix-spi-clock-names.patch
@@ -0,0 +1,32 @@
+From 6e58f781f2d5bedae9ff6991ac378212a392b723 Mon Sep 17 00:00:00 2001
+From: Sascha Hauer <s.hauer@pengutronix.de>
+Date: Fri, 20 Mar 2009 19:25:01 +0100
+Subject: [PATCH 09/28] MX31 Fix spi clock names
+
+Fix the SPI clock names to match the device names.
+
+Signed-off-by: Sascha Hauer <s.hauer@pengutronix.de>
+---
+ arch/arm/mach-mx3/clock.c | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/arch/arm/mach-mx3/clock.c b/arch/arm/mach-mx3/clock.c
+index f25e8be..664148c 100644
+--- a/arch/arm/mach-mx3/clock.c
++++ b/arch/arm/mach-mx3/clock.c
+@@ -518,9 +518,9 @@ DEFINE_CLOCK(ipg_clk, 0, NULL, 0, ipg_get_rate, NULL, &ahb_clk);
+
+ static struct clk_lookup lookups[] = {
+ _REGISTER_CLOCK(NULL, "emi", emi_clk)
+- _REGISTER_CLOCK(NULL, "cspi", cspi1_clk)
+- _REGISTER_CLOCK(NULL, "cspi", cspi2_clk)
+- _REGISTER_CLOCK(NULL, "cspi", cspi3_clk)
++ _REGISTER_CLOCK("spi_imx.0", NULL, cspi1_clk)
++ _REGISTER_CLOCK("spi_imx.1", NULL, cspi2_clk)
++ _REGISTER_CLOCK("spi_imx.2", NULL, cspi3_clk)
+ _REGISTER_CLOCK(NULL, "gpt", gpt_clk)
+ _REGISTER_CLOCK(NULL, "pwm", pwm_clk)
+ _REGISTER_CLOCK(NULL, "wdog", wdog_clk)
+--
+1.6.5.2
+