aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux-atm/linux-atm_2.4.1.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux-atm/linux-atm_2.4.1.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux-atm/linux-atm_2.4.1.bb')
-rw-r--r--recipes/linux-atm/linux-atm_2.4.1.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes/linux-atm/linux-atm_2.4.1.bb b/recipes/linux-atm/linux-atm_2.4.1.bb
new file mode 100644
index 0000000000..2643c742d5
--- /dev/null
+++ b/recipes/linux-atm/linux-atm_2.4.1.bb
@@ -0,0 +1,49 @@
+DESCRIPTION = "Drivers and tools to support ATM networking under Linux"
+HOMEPAGE = "http://linux-atm.sourceforge.net/"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "virtual/kernel"
+PR = "r1"
+LICENSE = "GPL LGPL"
+
+SRC_URI = "http://heanet.dl.sourceforge.net/sourceforge/linux-atm/linux-atm-${PV}.tar.gz \
+ file://gcc-3.4-fix;patch=1 \
+ file://qgen-cross;patch=1"
+S = "${WORKDIR}/linux-atm-${PV}"
+
+inherit autotools pkgconfig flow-lossage
+
+
+headers_include="atmd.h atm.h atmsap.h"
+headers_arpd="atmarp.h atmarpd.h"
+
+binarys_sbin="maint/atmaddr maint/atmloop lane/bus ilmid/ilmid mpoad/mpcd arpd/atmarp sigd/atmsigd maint/enitune lane/lecs led/zeppelin arpd/atmarpd maint/atmtcp maint/esi lane/les maint/zntune"
+binarys_bin="test/aread maint/atmdiag maint/atmdump test/awrite maint/saaldump maint/sonetdiag test/ttcp_atm"
+
+
+do_compile_prepend() {
+ oe_runmake -C ${S}/src/qgen AR='${BUILD_AR}' CPP='${BUILD_CPP}' CC='${BUILD_CC}' CFLAGS='${BUILD_CFLAGS}' DEFS='-I${S}/src -I. -I../.. -DHAVE_CONFIG_H' CPPFLAGS='${BUILD_CPPFLAGS}' LD='${BUILD_LD}' LDFLAGS='${BUILD_LDFLAGS}' qgen q.dump
+ oe_runmake -C ${S}/src/qgen DEFS='-I${S}/src -I. -I../.. -DHAVE_CONFIG_H' all
+}
+
+do_stage () {
+ oe_libinstall -so -C src/lib libatm ${STAGING_LIBDIR}
+
+ for i in ${headers_include}; do
+ install -m 0644 src/include/$i ${STAGING_INCDIR}/$i
+ done
+
+ for i in ${headers_arpd}; do
+ install -m 0644 src/arpd/$i ${STAGING_INCDIR}/$i
+ done
+
+ for i in ${binarys_sbin}; do
+ install -m 0755 src/$i ${STAGING_BINDIR}/`basename $i`
+ done
+
+ for i in ${binarys_bin}; do
+ install -m 0755 src/$i ${STAGING_BINDIR}/`basename $i`
+ done
+}
+
+