aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libxine/libxine-1.1.16
diff options
context:
space:
mode:
authorwoglinde <heinold@inf.fu-berlin.de>2009-03-28 16:15:51 +0100
committerwoglinde <heinold@inf.fu-berlin.de>2009-03-31 10:01:05 +0200
commit01782313f289ff9cef1f2976db9b10bacfe8e2a5 (patch)
treef8464e8862495423cfddcc2fd3bca74dcd31a70e /recipes/libxine/libxine-1.1.16
parent20dc6592d98595aac0a107f4eb06e27b915ee0db (diff)
downloadopenembedded-01782313f289ff9cef1f2976db9b10bacfe8e2a5.tar.gz
libxine: remove older verison and add the actual 1.1.16
* dont seperate x11 and fb anymore xine can handle it via plugins * therefore all recipes wich depends on libxine-fb or libxine-x11 have to changed to libxine
Diffstat (limited to 'recipes/libxine/libxine-1.1.16')
-rw-r--r--recipes/libxine/libxine-1.1.16/iconv.patch12
-rw-r--r--recipes/libxine/libxine-1.1.16/libavcodec.patch26
-rw-r--r--recipes/libxine/libxine-1.1.16/libpostproc.patch34
-rw-r--r--recipes/libxine/libxine-1.1.16/libxine-arm-configure.patch18
4 files changed, 90 insertions, 0 deletions
diff --git a/recipes/libxine/libxine-1.1.16/iconv.patch b/recipes/libxine/libxine-1.1.16/iconv.patch
new file mode 100644
index 0000000000..d3c7cc8c6f
--- /dev/null
+++ b/recipes/libxine/libxine-1.1.16/iconv.patch
@@ -0,0 +1,12 @@
+Index: xine-lib-1.1.15/misc/libxine.pc.in
+===================================================================
+--- xine-lib-1.1.15.orig/misc/libxine.pc.in 2008-09-19 00:50:07.144738536 +0200
++++ xine-lib-1.1.15/misc/libxine.pc.in 2008-09-19 00:50:17.962908808 +0200
+@@ -23,6 +23,6 @@
+ Version: @XINE_MAJOR@.@XINE_MINOR@.@XINE_SUB@@XINE_PATCH@
+ Requires:
+ Libs: -L${libdir} -lxine
+-Libs.private: @ZLIB_LIBS@ @NET_LIBS@ @PTHREAD_LIBS@ @LIBICONV@ @RT_LIBS@
++Libs.private: @ZLIB_LIBS@ @NET_LIBS@ @PTHREAD_LIBS@ @LTLIBICONV@ @RT_LIBS@
+ Cflags: -I${includedir}
+ Cflags.private: @PTHREAD_CFLAGS@
diff --git a/recipes/libxine/libxine-1.1.16/libavcodec.patch b/recipes/libxine/libxine-1.1.16/libavcodec.patch
new file mode 100644
index 0000000000..c4ef887c3d
--- /dev/null
+++ b/recipes/libxine/libxine-1.1.16/libavcodec.patch
@@ -0,0 +1,26 @@
+Index: xine-lib-1.1.16/src/combined/ffmpeg/ffmpeg_decoder.h
+===================================================================
+--- xine-lib-1.1.16.orig/src/combined/ffmpeg/ffmpeg_decoder.h 2009-03-25 00:27:52.177883234 +0100
++++ xine-lib-1.1.16/src/combined/ffmpeg/ffmpeg_decoder.h 2009-03-25 00:27:58.048708749 +0100
+@@ -26,8 +26,6 @@
+ #endif
+
+ #ifdef HAVE_FFMPEG_AVUTIL_H
+-# include <avcodec.h>
+-#elif defined HAVE_FFMPEG
+ # include <libavcodec/avcodec.h>
+ #else
+ # include "../../libffmpeg/libavcodec/avcodec.h"
+Index: xine-lib-1.1.16/src/combined/ffmpeg/ff_dvaudio_decoder.c
+===================================================================
+--- xine-lib-1.1.16.orig/src/combined/ffmpeg/ff_dvaudio_decoder.c 2009-03-25 00:28:05.839130673 +0100
++++ xine-lib-1.1.16/src/combined/ffmpeg/ff_dvaudio_decoder.c 2009-03-25 00:28:28.411467638 +0100
+@@ -53,8 +53,6 @@
+ #endif
+
+ #ifdef HAVE_FFMPEG_AVUTIL_H
+-# include <avcodec.h>
+-#elif defined HAVE_FFMPEG
+ # include <libavcodec/avcodec.h>
+ #else
+ # include "../../libffmpeg/libavcodec/avcodec.h"
diff --git a/recipes/libxine/libxine-1.1.16/libpostproc.patch b/recipes/libxine/libxine-1.1.16/libpostproc.patch
new file mode 100644
index 0000000000..89f8a0c15c
--- /dev/null
+++ b/recipes/libxine/libxine-1.1.16/libpostproc.patch
@@ -0,0 +1,34 @@
+Index: xine-lib-1.1.16/src/post/planar/pp.c
+===================================================================
+--- xine-lib-1.1.16.orig/src/post/planar/pp.c 2009-03-25 00:11:21.375059193 +0100
++++ xine-lib-1.1.16/src/post/planar/pp.c 2009-03-25 00:11:51.259320837 +0100
+@@ -29,11 +29,7 @@
+ #include "xineutils.h"
+ #include <pthread.h>
+
+-#ifdef HAVE_FFMPEG_AVUTIL_H
+-# include <postprocess.h>
+-#else
+-# include <libpostproc/postprocess.h>
+-#endif
++#include <libpostproc/postprocess.h>
+
+ #define PP_STRING_SIZE 256 /* size of pp mode string (including all options) */
+
+Index: xine-lib-1.1.16/src/combined/ffmpeg/ff_video_decoder.c
+===================================================================
+--- xine-lib-1.1.16.orig/src/combined/ffmpeg/ff_video_decoder.c 2009-03-25 00:20:01.437924936 +0100
++++ xine-lib-1.1.16/src/combined/ffmpeg/ff_video_decoder.c 2009-03-25 00:20:16.771556770 +0100
+@@ -45,11 +45,7 @@
+ #include "ffmpeg_decoder.h"
+ #include "ff_mpeg_parser.h"
+
+-#ifdef HAVE_FFMPEG_AVUTIL_H
+-# include <postprocess.h>
+-#else
+-# include <libpostproc/postprocess.h>
+-#endif
++#include <libpostproc/postprocess.h>
+
+ #define VIDEOBUFSIZE (128*1024)
+ #define SLICE_BUFFER_SIZE (1194*1024)
diff --git a/recipes/libxine/libxine-1.1.16/libxine-arm-configure.patch b/recipes/libxine/libxine-1.1.16/libxine-arm-configure.patch
new file mode 100644
index 0000000000..6fc3bc1cd6
--- /dev/null
+++ b/recipes/libxine/libxine-1.1.16/libxine-arm-configure.patch
@@ -0,0 +1,18 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+Index: xine-lib-1.1.12/configure.ac
+===================================================================
+--- xine-lib-1.1.12.orig/configure.ac 2008-04-11 16:17:50.000000000 +0200
++++ xine-lib-1.1.12/configure.ac 2008-05-08 00:01:27.000000000 +0200
+@@ -2304,7 +2304,7 @@
+ alphaev56-* | alpha* | ia64-* | hppa*-linux-*)
+ AC_DEFINE_UNQUOTED(FPM_64BIT,,[Define to select libmad fixed point arithmetic implementation])
+ ;;
+- armv4l-*-linux*)
++ armv-*-linux*)
+ AC_DEFINE_UNQUOTED(FPM_ARM,,[Define to select libmad fixed point arithmetic implementation])
+ enable_armv4l="yes"
+ ;;