aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libsdl/libsdl-x11_1.2.14.bb
diff options
context:
space:
mode:
authorDavid-John Willis <John.Willis@Distant-earth.com>2009-11-28 08:35:32 +0000
committerKoen Kooi <koen@openembedded.org>2009-12-04 10:43:06 +0100
commitf0efa83cf3055a9085171804bb1182ab76eb70f6 (patch)
treebcd65118b2e0b72bd584746ebd6de9f0798af677 /recipes/libsdl/libsdl-x11_1.2.14.bb
parentba9ab8c783d196ed16b1b4d64b04ec20845323eb (diff)
downloadopenembedded-f0efa83cf3055a9085171804bb1182ab76eb70f6.tar.gz
libsdl: Add 1.2.14 (and native). Note: Does not use libsdl.inc as that has hacks for older SDL versions.
* Only tested on the OpenPandora under Angstrom currently.
Diffstat (limited to 'recipes/libsdl/libsdl-x11_1.2.14.bb')
-rw-r--r--recipes/libsdl/libsdl-x11_1.2.14.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/recipes/libsdl/libsdl-x11_1.2.14.bb b/recipes/libsdl/libsdl-x11_1.2.14.bb
new file mode 100644
index 0000000000..621f7b47c1
--- /dev/null
+++ b/recipes/libsdl/libsdl-x11_1.2.14.bb
@@ -0,0 +1,51 @@
+# Do not use the include in 1.2.14 as it has a lot of unneeded munging that applies to old versions.
+#require libsdl.inc
+
+DESCRIPTION = "Simple DirectMedia Layer (X11 and Framebuffer support)"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "alsa-lib mesa virtual/libx11 libxext tslib"
+DEPENDS_avr32 = "alsa-lib virtual/libx11 libxext tslib"
+PROVIDES = "virtual/libsdl"
+PR = "r1"
+
+SRC_URI = " \
+ http://www.libsdl.org/release/SDL-${PV}.tar.gz \
+"
+
+S = "${WORKDIR}/SDL-${PV}"
+
+inherit autotools binconfig pkgconfig
+
+EXTRA_OECONF = " \
+ --disable-static --disable-debug --enable-cdrom --enable-threads --enable-timers --enable-endian \
+ --enable-file --enable-oss --enable-alsa --disable-esd --disable-arts \
+ --disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \
+ --disable-mintaudio --disable-nasm --enable-video-x11 --disable-video-dga \
+ --enable-video-fbcon --disable-video-directfb --disable-video-ps2gs \
+ --disable-video-xbios --disable-video-gem --disable-video-dummy \
+ --enable-video-opengl --enable-input-events --enable-pthreads \
+ --disable-video-picogui --disable-video-qtopia --enable-dlopen \
+ --enable-input-tslib \
+"
+
+do_configure() {
+ oe_runconf
+}
+
+do_configure_append () {
+ cd ${S}
+
+ # prevent libtool from linking libs against libstdc++, libgcc, ...
+ cat ${TARGET_PREFIX}libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${TARGET_PREFIX}libtool.tmp
+ mv ${TARGET_PREFIX}libtool.tmp ${TARGET_PREFIX}libtool
+}
+
+do_stage() {
+ autotools_stage_all
+ rm ${STAGING_LIBDIR}/libSDL.la
+}
+
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir}/*config"