aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libsdl/libsdl-net_1.2.7.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libsdl/libsdl-net_1.2.7.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libsdl/libsdl-net_1.2.7.bb')
-rw-r--r--recipes/libsdl/libsdl-net_1.2.7.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/libsdl/libsdl-net_1.2.7.bb b/recipes/libsdl/libsdl-net_1.2.7.bb
new file mode 100644
index 0000000000..8cbea5bd01
--- /dev/null
+++ b/recipes/libsdl/libsdl-net_1.2.7.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Simple DirectMedia Layer networking library."
+SECTION = "libs/network"
+PRIORITY = "optional"
+DEPENDS = "virtual/libsdl"
+LICENSE = "LGPL"
+PR = "r1"
+
+SRC_URI = "http://www.libsdl.org/projects/SDL_net/release/SDL_net-${PV}.tar.gz \
+ file://libtool2.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/SDL_net-${PV}"
+
+inherit autotools
+
+EXTRA_OECONF += "SDL_CONFIG=${STAGING_BINDIR_CROSS}/sdl-config"
+
+do_stage() {
+ autotools_stage_all
+}
+