aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libnl
diff options
context:
space:
mode:
authorAlexander Smirnov <Alexander.Smirnov@siemens.com>2011-04-12 19:50:59 +0400
committerDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2011-06-16 18:38:48 +0400
commit9fef5f074ca2685f07c288ce7cc2799b757ab750 (patch)
tree7f6f1458a417ce35ab0b3acdf7f277a328b76bff /recipes/libnl
parente0d8eb830afc8ccfe57ed91bea017fdeddd7c663 (diff)
downloadopenembedded-9fef5f074ca2685f07c288ce7cc2799b757ab750.tar.gz
Add 'ucred' structure declaration in netlink headers for the integrity
Signed-off-by: Alexander Smirnov <alex.bluesman.smirnov@gmail.com> Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Diffstat (limited to 'recipes/libnl')
-rw-r--r--recipes/libnl/libnl1-1.1/fix-ucred-declaration.patch23
-rw-r--r--recipes/libnl/libnl1_1.1.bb1
2 files changed, 24 insertions, 0 deletions
diff --git a/recipes/libnl/libnl1-1.1/fix-ucred-declaration.patch b/recipes/libnl/libnl1-1.1/fix-ucred-declaration.patch
new file mode 100644
index 0000000000..e31b18e5a5
--- /dev/null
+++ b/recipes/libnl/libnl1-1.1/fix-ucred-declaration.patch
@@ -0,0 +1,23 @@
+diff -pruN libnl-1.1.orig/include/netlink/handlers.h libnl-1.1/include/netlink/handlers.h
+--- libnl-1.1.orig/include/netlink/handlers.h 2008-01-14 18:48:45.000000000 +0300
++++ libnl-1.1/include/netlink/handlers.h 2011-04-12 19:23:16.603292527 +0400
+@@ -120,6 +120,7 @@ extern struct nl_cb * nl_cb_alloc(enum n
+ extern struct nl_cb * nl_cb_clone(struct nl_cb *);
+ extern struct nl_cb * nl_cb_get(struct nl_cb *);
+ extern void nl_cb_put(struct nl_cb *);
++struct ucred;
+
+ extern int nl_cb_set(struct nl_cb *, enum nl_cb_type, enum nl_cb_kind,
+ nl_recvmsg_msg_cb_t, void *);
+diff -pruN libnl-1.1.orig/include/netlink/netlink.h libnl-1.1/include/netlink/netlink.h
+--- libnl-1.1.orig/include/netlink/netlink.h 2008-01-14 18:48:45.000000000 +0300
++++ libnl-1.1/include/netlink/netlink.h 2011-04-12 19:23:51.370292658 +0400
+@@ -50,6 +50,8 @@ extern int nl_send_auto_complete(struc
+ extern int nl_send_simple(struct nl_handle *, int, int,
+ void *, size_t);
+
++struct ucred;
++
+ /* Receive */
+ extern int nl_recv(struct nl_handle *,
+ struct sockaddr_nl *, unsigned char **,
diff --git a/recipes/libnl/libnl1_1.1.bb b/recipes/libnl/libnl1_1.1.bb
index 3569867cc0..7ce3012bae 100644
--- a/recipes/libnl/libnl1_1.1.bb
+++ b/recipes/libnl/libnl1_1.1.bb
@@ -15,6 +15,7 @@ SRC_URI = "\
file://netlink-local-fix.patch \
file://dont-link-libnl-from-sysroot.patch \
file://build.only.static.lib.patch \
+ file://fix-ucred-declaration.patch \
"
S = "${WORKDIR}/libnl-${PV}"