summaryrefslogtreecommitdiffstats
path: root/recipes/libnet/libnet_1.0.2a.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libnet/libnet_1.0.2a.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libnet/libnet_1.0.2a.bb')
-rw-r--r--recipes/libnet/libnet_1.0.2a.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes/libnet/libnet_1.0.2a.bb b/recipes/libnet/libnet_1.0.2a.bb
new file mode 100644
index 0000000000..c633327181
--- /dev/null
+++ b/recipes/libnet/libnet_1.0.2a.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "Libnet is a collection of routines to help with \
+the construction and handling of network packets. It provides a \
+portable framework for low-level network packet shaping, \
+handling, and injection."
+SECTION = "libs/network"
+LICENSE = "GPL"
+PR = "r1"
+
+# There are major API changes beween libnet v1.0 and libnet v1.1
+PROVIDES = "libnet-1.0"
+
+#SRC_URI = "http://www.packetfactory.net/libnet/dist/deprecated/libnet-${PV}.tar.gz \
+SRC_URI = "${DEBIAN_MIRROR}/main/libn/libnet0/libnet0_${PV}.orig.tar.gz \
+ file://configure.patch;patch=1 \
+ file://configure.uclibc.patch;patch=1 \
+ file://configure_x86-64-host.patch;patch=1 \
+ "
+S = "${WORKDIR}/libnet-${PV}.orig"
+
+inherit autotools
+
+CPPFLAGS_prepend = "-I${S}/libnet/include -DHAVE_PF_PACKET "
+EXTRA_OEMAKE = "'LIB_PREFIX=${libdir}/' 'MAN_PREFIX=${mandir}/' \
+ 'BIN_PREFIX=${bindir}/' 'INC_PREFIX=${includedir}/'"
+
+#FIXME: (fixing this would remove the need for configure.uclibc.patch above)
+do_configure() {
+ oe_runconf
+}
+
+do_stage() {
+ install -m 0755 libnet-config ${STAGING_BINDIR_CROSS}/
+ install -m 0644 include/libnet.h ${STAGING_INCDIR}/
+ install -d ${STAGING_INCDIR}/libnet
+ install -m 0644 include/libnet/libnet-headers.h ${STAGING_INCDIR}/libnet/
+ install -m 0644 include/libnet/libnet-functions.h ${STAGING_INCDIR}/libnet/
+ install -m 0644 include/libnet/libnet-structures.h ${STAGING_INCDIR}/libnet/
+ install -m 0644 include/libnet/libnet-macros.h ${STAGING_INCDIR}/libnet/
+ install -m 0644 include/libnet/libnet-asn1.h ${STAGING_INCDIR}/libnet/
+ install -m 0644 include/libnet/libnet-ospf.h ${STAGING_INCDIR}/libnet/
+ oe_libinstall -a -C lib libnet ${STAGING_LIBDIR}
+}