aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libffi
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-10-27 17:35:45 -0700
committerChris Larson <chris_larson@mentor.com>2010-11-02 18:39:03 -0700
commitc575ee87388a5bb679293b54a00bb784efbfab92 (patch)
tree65397221732f56b6f81ebe973f9a7ae7ba2b4212 /recipes/libffi
parenta6885693d3685f595e307c79e9925893fb9f8a0d (diff)
downloadopenembedded-c575ee87388a5bb679293b54a00bb784efbfab92.tar.gz
gnu-configize fixupskergoth/autotools
Signed-off-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'recipes/libffi')
-rw-r--r--recipes/libffi/libffi_2.0+gcc3.4.1.bb7
-rw-r--r--recipes/libffi/libffi_2.0+gcc4.3.2.bb8
2 files changed, 2 insertions, 13 deletions
diff --git a/recipes/libffi/libffi_2.0+gcc3.4.1.bb b/recipes/libffi/libffi_2.0+gcc3.4.1.bb
index ceb46b18fc..a392b3583c 100644
--- a/recipes/libffi/libffi_2.0+gcc3.4.1.bb
+++ b/recipes/libffi/libffi_2.0+gcc3.4.1.bb
@@ -4,7 +4,7 @@ LICENSE = "libffi"
PRIORITY = "optional"
PR = "r1"
-inherit autotools gettext
+inherit autotools_base gettext
PACKAGES = "${PN}-dbg ${PN} ${PN}-dev"
@@ -43,11 +43,6 @@ EXTRA_OECONF = "--with-gnu-ld \
EXTRA_OECONF_PATHS = "--with-local-prefix=${prefix}/local \
--with-gxx-include-dir=${includedir}/c++/${PV}"
-do_configure () {
- (cd ${S}/.. && gnu-configize) || die "failure running gnu-configize"
- oe_runconf
-}
-
do_install_append() {
# follow debian and move this to $includedir
mv ${D}${libdir}/gcc/${TARGET_SYS}/${GCC_VER}/include/libffi/ffitarget.h ${D}${includedir}/
diff --git a/recipes/libffi/libffi_2.0+gcc4.3.2.bb b/recipes/libffi/libffi_2.0+gcc4.3.2.bb
index 1694ce4ab2..eb09f78d6e 100644
--- a/recipes/libffi/libffi_2.0+gcc4.3.2.bb
+++ b/recipes/libffi/libffi_2.0+gcc4.3.2.bb
@@ -4,7 +4,7 @@ DESCRIPTION = "Foreign Function Interface library"
LICENSE = "libffi"
PRIORITY = "optional"
-inherit autotools gettext
+inherit autotools_base gettext
PR = "r1"
@@ -57,12 +57,6 @@ EXTRA_OECONF_FPU = "${@get_gcc_fpu_setting(bb, d)}"
TARGET_CC_ARCH_append_armv6 = " -D__SOFTFP__"
TARGET_CC_ARCH_append_armv7a = " -D__SOFTFP__"
-
-do_configure () {
- (cd ${S}/.. && gnu-configize) || die "failure running gnu-configize"
- oe_runconf
-}
-
do_install_append() {
install_libffi_headers
}