aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/kexec-tools/kexec-tools-dietlibc-2.0.2
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2010-08-02 01:48:54 +0200
committerAndrea Adami <andrea.adami@gmail.com>2010-08-02 01:48:54 +0200
commit93e2f314df0434df3e1f3ae537129b9f7ee3e5de (patch)
treec936ee7e4834ea7bd134ac927f69466610a70087 /recipes/kexec-tools/kexec-tools-dietlibc-2.0.2
parentaa9c0c455fd36214f4b82cb1bd0e620e632389b0 (diff)
downloadopenembedded-93e2f314df0434df3e1f3ae537129b9f7ee3e5de.tar.gz
kexec-tools: move to 2.0.2 and remove older versions
* binary for klibc static only tested on arm * updated dietlibc version (not tested, dietlibc seems broken today...)
Diffstat (limited to 'recipes/kexec-tools/kexec-tools-dietlibc-2.0.2')
-rw-r--r--recipes/kexec-tools/kexec-tools-dietlibc-2.0.2/dietlibc.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes/kexec-tools/kexec-tools-dietlibc-2.0.2/dietlibc.patch b/recipes/kexec-tools/kexec-tools-dietlibc-2.0.2/dietlibc.patch
new file mode 100644
index 0000000000..97c9e1809c
--- /dev/null
+++ b/recipes/kexec-tools/kexec-tools-dietlibc-2.0.2/dietlibc.patch
@@ -0,0 +1,35 @@
+Index: kexec-tools-2.0.2/kexec/kexec-elf.c
+===================================================================
+--- kexec-tools-2.0.2.orig/kexec/kexec-elf.c 2009-10-03 14:19:35.347504269 +0200
++++ kexec-tools-2.0.2/kexec/kexec-elf.c 2009-10-03 14:23:00.414497203 +0200
+@@ -9,6 +9,17 @@
+ #include "kexec.h"
+ #include "kexec-elf.h"
+
++#ifdef __dietlibc__
++#include <limits.h>
++# define UINT32_MAX (4294967295U)
++# if __WORDSIZE == 64
++# define __UINT64_C(c) c ## UL
++# else
++# define __UINT64_C(c) c ## ULL
++# endif
++# define UINT64_MAX (__UINT64_C(18446744073709551615))
++#endif
++
+ static const int probe_debug = 0;
+
+ uint16_t elf16_to_cpu(const struct mem_ehdr *ehdr, uint16_t value)
+Index: kexec-tools-2.0.2/kexec/Makefile
+===================================================================
+--- kexec-tools-2.0.2.orig/kexec/Makefile 2009-10-03 14:43:59.574859089 +0200
++++ kexec-tools-2.0.2/kexec/Makefile 2009-10-03 14:44:08.190707689 +0200
+@@ -77,7 +77,7 @@
+
+ $(KEXEC): $(KEXEC_OBJS) $(UTIL_LIB)
+ @$(MKDIR) -p $(@D)
+- $(LINK.o) -o $@ $^ $(LIBS)
++ $(LINK.o) -o $@ $^ $(LIBS) -lcompat
+
+ $(KEXEC): CPPFLAGS+=-I$(srcdir)/kexec/arch/$(ARCH)/include
+