summaryrefslogtreecommitdiffstats
path: root/recipes/kanjipad/files
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/kanjipad/files
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/kanjipad/files')
-rw-r--r--recipes/kanjipad/files/Makefile-kpengine-only.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes/kanjipad/files/Makefile-kpengine-only.patch b/recipes/kanjipad/files/Makefile-kpengine-only.patch
new file mode 100644
index 0000000000..5ea650e4e7
--- /dev/null
+++ b/recipes/kanjipad/files/Makefile-kpengine-only.patch
@@ -0,0 +1,38 @@
+--- kanjipad-2.0.0.orig/Makefile 2002-08-25 21:00:54 +0200
++++ kanjipad-2.0.0/Makefile 2005-08-07 23:04:03 +0200
+@@ -5,7 +5,7 @@
+ GTKLIBS=$(shell pkg-config --libs gtk+-2.0)
+ GLIBLIBS=$(shell pkg-config --libs glib-2.0)
+
+-PREFIX=/usr/local
++PREFIX=/usr
+ DATADIR=$(PREFIX)/share
+
+ # location in which binaries are installed
+@@ -28,7 +28,7 @@
+ OBJS = kpengine.o scoring.o util.o
+ CFLAGS = $(OPTIMIZE) $(GTKINC) -DFOR_PILOT_COMPAT -DKP_LIBDIR=\"$(LIBDIR)\" -DBINDIR=\"$(BINDIR)\"
+
+-all: kpengine kanjipad jdata.dat
++all: kpengine jdata.dat
+
+ scoring.o: jstroke/scoring.c
+ $(CC) -c -o scoring.o $(CFLAGS) -Ijstroke jstroke/scoring.c
+@@ -45,9 +45,8 @@
+ jdata.dat: jstroke/strokedata.h conv_jdata.pl
+ perl conv_jdata.pl < jstroke/strokedata.h > jdata.dat
+
+-install: kanjipad kpengine jdata.dat
++install: kpengine jdata.dat
+ install -d $(DESTDIR)$(BINDIR)
+- install -m 0755 kanjipad $(DESTDIR)$(BINDIR)/kanjipad
+ install -m 0755 kpengine $(DESTDIR)$(BINDIR)/kpengine
+ install -d $(DESTDIR)$(LIBDIR)
+ install -m 0644 jdata.dat $(DESTDIR)$(LIBDIR)/jdata.dat
+@@ -75,4 +74,4 @@
+ cd .. && \
+ rm -rf $$distdir
+
+-.PHONY: dist distcheck
+\ No newline at end of file
++.PHONY: dist distcheck