aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/htmldoc/htmldoc_1.8.27.bb
diff options
context:
space:
mode:
authorVitus Jensen <vjensen@gmx.de>2010-09-06 13:54:03 +0000
committerKhem Raj <raj.khem@gmail.com>2010-10-13 21:30:28 -0700
commita4091df206a67ce8212f2eb0b602b5179b894579 (patch)
tree9877858241d119e171591c510962e22cd73263ef /recipes/htmldoc/htmldoc_1.8.27.bb
parent8a88368dbe21674fbe9ede83898fdcd7d0c18d14 (diff)
downloadopenembedded-a4091df206a67ce8212f2eb0b602b5179b894579.tar.gz
htmldoc_1.8.27:: merge native and non-native recipes
Signed-off-by: Vitus Jensen <vjensen@gmx.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/htmldoc/htmldoc_1.8.27.bb')
-rw-r--r--recipes/htmldoc/htmldoc_1.8.27.bb17
1 files changed, 14 insertions, 3 deletions
diff --git a/recipes/htmldoc/htmldoc_1.8.27.bb b/recipes/htmldoc/htmldoc_1.8.27.bb
index bb5ce8b78a..84df876226 100644
--- a/recipes/htmldoc/htmldoc_1.8.27.bb
+++ b/recipes/htmldoc/htmldoc_1.8.27.bb
@@ -1,10 +1,11 @@
require htmldoc.inc
-DEPENDS += "htmldoc-native"
-PR = "r2"
+DEPENDS_pn-htmldoc += "htmldoc-native"
+PR = "r3"
SRC_URI = "http://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/htmldoc/${PV}/htmldoc-${PV}-source.tar.bz2 \
-file://paths_1.8.27.patch"
+ file://paths_1.8.27.patch \
+ "
inherit autotools pkgconfig
@@ -16,6 +17,16 @@ EXTRA_OECONF += "--disable-localpng --disable-localjpeg --disable-localzlib \
FILES_${PN} += "${datadir}/htmldoc/fonts"
FILES_${PN} += "${datadir}/htmldoc/data"
+BBCLASSEXTEND = "native"
+
+do_compile_virtclass-native() {
+ (cd htmldoc && oe_runmake all)
+}
+do_install_virtclass-native() {
+ (cd fonts && oe_runmake 'DESTDIR=${D}' install)
+ (cd data && oe_runmake 'DESTDIR=${D}' install)
+ (cd htmldoc && oe_runmake 'DESTDIR=${D}' install)
+}
do_install() {
oe_runmake 'DESTDIR=${D}' install