aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gspcav1/files
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gspcav1/files
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gspcav1/files')
-rw-r--r--recipes/gspcav1/files/MS.patch29
-rw-r--r--recipes/gspcav1/files/Makefile.patch11
2 files changed, 40 insertions, 0 deletions
diff --git a/recipes/gspcav1/files/MS.patch b/recipes/gspcav1/files/MS.patch
new file mode 100644
index 0000000000..588a4bc3da
--- /dev/null
+++ b/recipes/gspcav1/files/MS.patch
@@ -0,0 +1,29 @@
+--- gspcav1-20070110/gspca_core.c.orig 2007-03-16 23:24:37.000000000 +0000
++++ gspcav1-20070110/gspca_core.c 2007-03-16 23:24:43.000000000 +0000
+@@ -398,7 +398,7 @@
+ Sonyc002,
+ Vimicro0321,
+ Orbicam,
+- M$VX1000,
++ MSVX1000,
+ Trust610LCDPowerCamZoom,
+ Sonyc001,
+ LastCamera
+@@ -580,7 +580,7 @@
+ {Sonyc002,"Vc0321"},
+ {Vimicro0321,"Vc0321"},
+ {Orbicam,"Logitech Orbicam"},
+- {M$VX1000,"MicroSoft VX1000"},
++ {MSVX1000,"MicroSoft VX1000"},
+ {Trust610LCDPowerCamZoom, "Trust 610 LCD PowerC@m Zoom"},
+ {Sonyc001,"Sony Visual Communication VGP-VCC1"},
+ {-1, NULL}
+@@ -3124,7 +3124,7 @@
+ case 0x045e:
+ switch(product){
+ case 0x00f7:
+- spca50x->desc = M$VX1000;
++ spca50x->desc = MSVX1000;
+ spca50x->bridge = BRIDGE_SN9CXXX;
+ spca50x->sensor = SENSOR_OV7660;
+ spca50x->customid = SN9C105;
diff --git a/recipes/gspcav1/files/Makefile.patch b/recipes/gspcav1/files/Makefile.patch
new file mode 100644
index 0000000000..87262686cb
--- /dev/null
+++ b/recipes/gspcav1/files/Makefile.patch
@@ -0,0 +1,11 @@
+--- gspcav1-20070110/Makefile.orig 2007-03-16 23:20:18.000000000 +0000
++++ gspcav1-20070110/Makefile 2007-03-16 23:20:44.000000000 +0000
+@@ -41,7 +41,7 @@
+ MODULE_INSTALLDIR2 = /lib/modules/$(KERNEL_VERSION)/kernel/drivers/media/video/
+
+ default:
+- $(MAKE) -C $(KERNELDIR) SUBDIRS=$(PWD) CC=$(CC) modules
++ $(MAKE) -C $(KERNELDIR) SUBDIRS=$(PWD) CC="$(CC)" modules
+
+ install:
+ mkdir -p $(MODULE_INSTALLDIR)