aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome
diff options
context:
space:
mode:
authorSteve Sakoman <steve@sakoman.com>2011-04-04 14:07:56 -0700
committerKoen Kooi <koen@openembedded.org>2011-05-08 20:24:29 +0200
commit27051bc6ccacbc5218e5847d2843003aef6d8ec0 (patch)
tree48029de63548cc1940a04499178870aee84d6199 /recipes/gnome
parent9de8acb3965ab309d0c426b318da9a69841a3129 (diff)
downloadopenembedded-27051bc6ccacbc5218e5847d2843003aef6d8ec0.tar.gz
gnome-bluetooth: Add recipe for 2.32.0
Signed-off-by: Steve Sakoman <steve@sakoman.com> Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/gnome')
-rw-r--r--recipes/gnome/gnome-bluetooth_2.32.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/gnome/gnome-bluetooth_2.32.0.bb b/recipes/gnome/gnome-bluetooth_2.32.0.bb
new file mode 100644
index 0000000000..3ab181ccfe
--- /dev/null
+++ b/recipes/gnome/gnome-bluetooth_2.32.0.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "GNOME bluetooth manager"
+LICENSE = "GPL"
+SECTION = "x11/gnome"
+DEPENDS = "gnome-doc-utils-native obexd obex-data-server gconf gtk+ dbus-glib libunique libnotify hal bluez4 gnome-keyring libx11 libxi"
+
+inherit gnome
+
+SRC_URI[archive.md5sum] = "f129686fe46c4c98eb70a0cc85d59cae"
+SRC_URI[archive.sha256sum] = "57b1f06c96a1b85e1c19ff919d708cc38e95edae658881ed99968c325839a973"
+
+# No 'nautilus-sendto' recipe in OE yet
+EXTRA_OECONF += "--enable-nautilus-sendto=no"
+
+# No native docbook XSL stylesheets recipe in OE yet
+do_configure_prepend() {
+ sed -i s/help// Makefile.am
+}
+
+do_configure_append() {
+ sed -i 's,func_fatal_error "error: cannot install,echo "bogus message about,' ${HOST_SYS}-libtool
+}
+
+RRECOMMENDS_${PN} += "obexd obex-data-server"
+RCONFLICTS_${PN} = "bluez-gnome"
+
+FILES_${PN}-dbg += "${libdir}/gnome-bluetooth/plugins/.debug/"