aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-03-23 15:20:19 +0300
committerRoman I Khimov <khimov@altell.ru>2010-03-25 09:28:26 +0300
commit658ae76b938a90ac3587909f6b8525559fe57b56 (patch)
tree9216406ea230a65552429cb71c190c0e00d04c2d /recipes/gnome
parente0f9409803d6edc14608828967c0c52b5a2d182e (diff)
downloadopenembedded-658ae76b938a90ac3587909f6b8525559fe57b56.tar.gz
use PYTHON_SITEPACKAGES_DIR
Converted most of python site-packages references to PYTHON_SITEPACKAGES_DIR. Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/gnome')
-rw-r--r--recipes/gnome/gnome-games_2.24.3.bb4
-rw-r--r--recipes/gnome/gnome-menus_2.16.1.bb6
-rw-r--r--recipes/gnome/gnome-menus_2.22.2.bb6
-rw-r--r--recipes/gnome/gnome-menus_2.24.0.bb6
-rw-r--r--recipes/gnome/gnome-menus_2.26.0.bb6
-rw-r--r--recipes/gnome/gnome-menus_2.28.0.1.bb6
-rw-r--r--recipes/gnome/hippo-canvas_0.3.0.bb6
7 files changed, 20 insertions, 20 deletions
diff --git a/recipes/gnome/gnome-games_2.24.3.bb b/recipes/gnome/gnome-games_2.24.3.bb
index f290f61342..2fed74baab 100644
--- a/recipes/gnome/gnome-games_2.24.3.bb
+++ b/recipes/gnome/gnome-games_2.24.3.bb
@@ -213,7 +213,7 @@ FILES_gnome-games-glchess = "${bindir}/glchess \
${datadir}/pixmaps/gnome-glchess.png \
${datadir}/applications/glchess.desktop \
${sysconfdir}/gconf/schemas/glchess.schemas \
- ${libdir}/python2.5/site-packages/glchess"
+ ${PYTHON_SITEPACKAGES_DIR}/glchess"
PACKAGES =+ "gnome-games-sudoku"
DESCRIPTION_gnome-games-sudoku = "GNOME sudoku"
@@ -226,4 +226,4 @@ FILES_gnome-games-sudoku = "${bindir}/gnome-sudoku \
${datadir}/gnome-sudoku \
${datadir}/pixmaps/gnome-sudoku.png \
${datadir}/applications/gnome-sudoku.desktop \
- ${libdir}/python2.5/site-packages/gnome_sudoku"
+ ${PYTHON_SITEPACKAGES_DIR}/gnome_sudoku"
diff --git a/recipes/gnome/gnome-menus_2.16.1.bb b/recipes/gnome/gnome-menus_2.16.1.bb
index 1307c026f2..16ca59c58c 100644
--- a/recipes/gnome/gnome-menus_2.16.1.bb
+++ b/recipes/gnome/gnome-menus_2.16.1.bb
@@ -3,7 +3,7 @@ LICENSE = "GPL"
PR = "r1"
-inherit gnome pkgconfig
+inherit gnome pkgconfig python-dir
do_stage() {
autotools_stage_all
@@ -12,6 +12,6 @@ autotools_stage_all
PACKAGES += "${PN}-python"
FILES_${PN} += "${datadir}/desktop-directories/"
FILES_${PN}-python = "${libdir}/python*"
-FILES_${PN}-dbg += "${libdir}/python*/site-packages/*/.debug \
- ${libdir}/python*/site-packages/.debug"
+FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/*/.debug \
+ ${PYTHON_SITEPACKAGES_DIR}/.debug"
diff --git a/recipes/gnome/gnome-menus_2.22.2.bb b/recipes/gnome/gnome-menus_2.22.2.bb
index 5837e7fed2..8596f1f46c 100644
--- a/recipes/gnome/gnome-menus_2.22.2.bb
+++ b/recipes/gnome/gnome-menus_2.22.2.bb
@@ -1,7 +1,7 @@
DEPENDS = "python gnome-vfs libxml2 gconf popt gtk+"
LICENSE = "GPL"
-inherit gnome pkgconfig
+inherit gnome pkgconfig python-dir
do_stage() {
autotools_stage_all
@@ -10,6 +10,6 @@ autotools_stage_all
PACKAGES += "${PN}-python"
FILES_${PN} += "${datadir}/desktop-directories/"
FILES_${PN}-python = "${libdir}/python*"
-FILES_${PN}-dbg += "${libdir}/python*/site-packages/*/.debug \
- ${libdir}/python*/site-packages/.debug"
+FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/*/.debug \
+ ${PYTHON_SITEPACKAGES_DIR}/.debug"
diff --git a/recipes/gnome/gnome-menus_2.24.0.bb b/recipes/gnome/gnome-menus_2.24.0.bb
index 5837e7fed2..8596f1f46c 100644
--- a/recipes/gnome/gnome-menus_2.24.0.bb
+++ b/recipes/gnome/gnome-menus_2.24.0.bb
@@ -1,7 +1,7 @@
DEPENDS = "python gnome-vfs libxml2 gconf popt gtk+"
LICENSE = "GPL"
-inherit gnome pkgconfig
+inherit gnome pkgconfig python-dir
do_stage() {
autotools_stage_all
@@ -10,6 +10,6 @@ autotools_stage_all
PACKAGES += "${PN}-python"
FILES_${PN} += "${datadir}/desktop-directories/"
FILES_${PN}-python = "${libdir}/python*"
-FILES_${PN}-dbg += "${libdir}/python*/site-packages/*/.debug \
- ${libdir}/python*/site-packages/.debug"
+FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/*/.debug \
+ ${PYTHON_SITEPACKAGES_DIR}/.debug"
diff --git a/recipes/gnome/gnome-menus_2.26.0.bb b/recipes/gnome/gnome-menus_2.26.0.bb
index 5837e7fed2..8596f1f46c 100644
--- a/recipes/gnome/gnome-menus_2.26.0.bb
+++ b/recipes/gnome/gnome-menus_2.26.0.bb
@@ -1,7 +1,7 @@
DEPENDS = "python gnome-vfs libxml2 gconf popt gtk+"
LICENSE = "GPL"
-inherit gnome pkgconfig
+inherit gnome pkgconfig python-dir
do_stage() {
autotools_stage_all
@@ -10,6 +10,6 @@ autotools_stage_all
PACKAGES += "${PN}-python"
FILES_${PN} += "${datadir}/desktop-directories/"
FILES_${PN}-python = "${libdir}/python*"
-FILES_${PN}-dbg += "${libdir}/python*/site-packages/*/.debug \
- ${libdir}/python*/site-packages/.debug"
+FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/*/.debug \
+ ${PYTHON_SITEPACKAGES_DIR}/.debug"
diff --git a/recipes/gnome/gnome-menus_2.28.0.1.bb b/recipes/gnome/gnome-menus_2.28.0.1.bb
index 72fc810395..461d3eb543 100644
--- a/recipes/gnome/gnome-menus_2.28.0.1.bb
+++ b/recipes/gnome/gnome-menus_2.28.0.1.bb
@@ -4,7 +4,7 @@ LICENSE = "GPL"
DEPENDS = "python gnome-vfs libxml2 gconf popt gtk+"
-inherit gnome pkgconfig
+inherit gnome pkgconfig python-dir
do_stage() {
autotools_stage_all
@@ -13,6 +13,6 @@ do_stage() {
PACKAGES += "${PN}-python"
FILES_${PN} += "${datadir}/desktop-directories/"
FILES_${PN}-python = "${libdir}/python*"
-FILES_${PN}-dbg += "${libdir}/python*/site-packages/*/.debug \
- ${libdir}/python*/site-packages/.debug"
+FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/*/.debug \
+ ${PYTHON_SITEPACKAGES_DIR}/.debug"
diff --git a/recipes/gnome/hippo-canvas_0.3.0.bb b/recipes/gnome/hippo-canvas_0.3.0.bb
index 2c6da440bb..1e24377a36 100644
--- a/recipes/gnome/hippo-canvas_0.3.0.bb
+++ b/recipes/gnome/hippo-canvas_0.3.0.bb
@@ -3,7 +3,7 @@ LICENSE = "LGPLv2"
DEPENDS = "librsvg python-pygtk2"
-inherit gnome
+inherit gnome python-dir
DEPENDS += "librsvg"
@@ -17,7 +17,7 @@ do_stage() {
autotools_stage_all
}
-FILES_${PN} += "${libdir}/python*/site-packages"
-FILES_${PN}-dbg += "${libdir}/python*/site-packages/.debug"
+FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"
+FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/.debug"