aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome/libbonoboui_2.24.1.bb
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2009-08-15 15:01:02 +0100
committerGraeme Gregory <dp@xora.org.uk>2009-08-15 15:01:02 +0100
commitb9aba715404627590e9d406eda19d3fb6eb30aa4 (patch)
tree05609574a4d2bf98b51900f1b53e37ff0283983c /recipes/gnome/libbonoboui_2.24.1.bb
parent321f298f4b9477ce563eeef68d82a28366788a52 (diff)
parent55afc69df3bedfc5d5c7d73a7debc8307edf40a6 (diff)
downloadopenembedded-b9aba715404627590e9d406eda19d3fb6eb30aa4.tar.gz
Merge branch 'org.openembedded.dev' of /home/dp/openembedded/org.openembedded.dev into xora/angstrom-srcpv
Conflicts: recipes/linux/linux-omap_git.bb recipes/u-boot/u-boot_git.bb
Diffstat (limited to 'recipes/gnome/libbonoboui_2.24.1.bb')
-rw-r--r--recipes/gnome/libbonoboui_2.24.1.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/recipes/gnome/libbonoboui_2.24.1.bb b/recipes/gnome/libbonoboui_2.24.1.bb
new file mode 100644
index 0000000000..447dc2e8ae
--- /dev/null
+++ b/recipes/gnome/libbonoboui_2.24.1.bb
@@ -0,0 +1,61 @@
+#DEFAULT_PREFERENCE = "-1"
+
+LICENSE = "GPL"
+SECTION = "x11/gnome/libs"
+PR = "r0"
+
+inherit gnome pkgconfig
+
+FILES_${PN} += "${libdir}/libglade/2.0/*.so"
+FILES_${PN}-dev += "${libdir}/libglade/2.0/* ${datadir}/gnome-2.0/ui \
+ ${libdir}/bonobo-2.0/samples"
+FILES_${PN}-dbg += "${libdir}/bonobo-2.0/samples/.debug \
+ ${libdir}/libglade/2.0/.debug"
+
+DEPENDS = "libgnomecanvas libbonobo libgnome glib-2.0 gtk-doc gconf libxml2 libglade"
+
+EXTRA_OECONF = "--disable-gtk-doc"
+
+HEADERS = " \
+bonobo/bonobo-zoomable.h \
+bonobo/bonobo-ui-component.h \
+bonobo/bonobo-dock-layout.h \
+bonobo/bonobo-ui-type-builtins.h \
+bonobo/bonobo-canvas-component.h \
+bonobo/bonobo-widget.h \
+bonobo/bonobo-ui-engine.h \
+bonobo/bonobo-window.h \
+bonobo/bonobo-ui-toolbar.h \
+bonobo/bonobo-dock-band.h \
+bonobo/bonobo-ui-toolbar-item.h \
+bonobo/bonobo-control.h \
+bonobo/bonobo-dock-item.h \
+bonobo/bonobo-ui-config-widget.h \
+bonobo/bonobo-zoomable-frame.h \
+bonobo/bonobo-control-frame.h \
+bonobo/bonobo-dock.h \
+bonobo/bonobo-ui-main.h \
+bonobo/bonobo-canvas-item.h \
+bonobo/bonobo-ui-node.h \
+bonobo/bonobo-socket.h \
+bonobo/bonobo-selector.h \
+bonobo/bonobo-ui-sync.h \
+bonobo/bonobo-ui-util.h \
+bonobo/bonobo-plug.h \
+bonobo/bonobo-ui-toolbar-button-item.h \
+bonobo/bonobo-ui-toolbar-toggle-button-item.h \
+bonobo/bonobo-ui-container.h \
+bonobo/bonobo-file-selector-util.h \
+bonobo/bonobo-property-control.h \
+bonobo/bonobo-selector-widget.h \
+libbonoboui.h \
+bonobo.h \
+"
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/libbonoboui-2.0/bonobo
+ for i in ${HEADERS}; do
+ install -m 0644 $i ${STAGING_INCDIR}/libbonoboui-2.0/$i
+ done
+ oe_libinstall -C bonobo -a -so libbonoboui-2 ${STAGING_LIBDIR}
+}