summaryrefslogtreecommitdiffstats
path: root/recipes/gmu/gmu_0.7.1.bb
diff options
context:
space:
mode:
authorAlex Ferguson <thoughtmonster@gmail.com>2010-10-30 21:42:28 +0300
committerKristoffer Ericson <kristoffer.ericson@gmail.com>2010-11-03 16:51:16 +0100
commit6c8af6f29e173a62e881be442b8dc4f2b1efde17 (patch)
treeec799dfedf6bbfc27b6f3e54f65caa6dc827e92c /recipes/gmu/gmu_0.7.1.bb
parent20a3853a49d2fdba7421841b5f22b8800fdb37ca (diff)
downloadopenembedded-6c8af6f29e173a62e881be442b8dc4f2b1efde17.tar.gz
gmu: Add recipe for gmu-0.7.1, a music player based on SDL.
* Added Makefile, which adds an install hook and adds the INCS and LIBS variables, due to the way OE handles CFLAGS and LDFLAGS. * Added unknown.mk, the generic mk file, which replaces the version shipped with gmu and fixes compilation in OE. * Added gmu.desktop, which uses the generic audio-player icon. * Added two additional files, nanonote.keymap and nanonote.mk which are specific to ben-nanonote. * Added nanonote-lcd-blank.patch which fixes LCD blanking under the 2.6.36 kernel version for the ben-nanonote target. * Added set-base-dir.patch which sets proper systemwide directories for configuration files and libraries (decoders and frontends). gmu normally looks under pwd to find such files, which is extremely error-prone. Signed-off-by: Alex Ferguson <thoughtmonster@gmail.com> Signed-off-by: Kristoffer Ericson <kristoffer.ericson@gmail.com>
Diffstat (limited to 'recipes/gmu/gmu_0.7.1.bb')
-rw-r--r--recipes/gmu/gmu_0.7.1.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/recipes/gmu/gmu_0.7.1.bb b/recipes/gmu/gmu_0.7.1.bb
new file mode 100644
index 0000000000..a70a5a61e1
--- /dev/null
+++ b/recipes/gmu/gmu_0.7.1.bb
@@ -0,0 +1,50 @@
+DESCRIPTION = "Gmu is a music player for portable handheld consoles."
+HOMEPAGE = "http://wejp.k.vu/projects/gmu/"
+LICENSE = "GPLv2"
+PR = "r0"
+
+DEPENDS = "virtual/libsdl libsdl-image libsdl-gfx"
+RDEPENDS = "tremor flac mpg123"
+
+SRC_URI = "http://wejp.k.vu/files/gmu-${PV}.tar.gz \
+ file://nanonote-lcd-blank.patch \
+ file://set-base-dir.patch \
+ file://gmu.desktop \
+ file://unknown.mk \
+ file://Makefile"
+
+SRC_URI_append_ben-nanonote = " file://nanonote.mk file://nanonote.keymap "
+
+FILES_${PN}-dbg += " /usr/lib/gmu/frontends/.debug/ "
+CONFFILES_${PN} = "/etc/gmu/gmu.conf /etc/gmu/gmuinput.conf /etc/gmu/default.keymap"
+
+do_configure() {
+ mv ${WORKDIR}/Makefile ${S}/Makefile
+ mv ${WORKDIR}/unknown.mk ${S}/unknown.mk
+ mv ${S}/gmu.unknown.conf ${S}/gmu.conf
+ mv ${S}/gmuinput.unknown.conf ${S}/gmuinput.conf
+ sed -i 's/gmuinput.unknown.conf/gmuinput.conf/g' ${S}/gmu.conf
+}
+
+do_configure_ben-nanonote() {
+ mv ${WORKDIR}/Makefile ${S}/Makefile
+ mv ${WORKDIR}/nanonote.mk ${S}/nanonote.mk
+ mv ${WORKDIR}/nanonote.keymap ${S}/default.keymap
+ mv ${S}/gmu.nanonote.conf ${S}/gmu.conf
+ mv ${S}/gmuinput.nanonote.conf ${S}/gmuinput.conf
+ sed -i 's/gmuinput.nanonote.conf/gmuinput.conf/g' ${S}/gmu.conf
+ sed -i 's/nanonote.keymap/default.keymap/g' ${S}/gmu.conf
+}
+
+do_compile_prepend_ben-nanonote() {
+ export TARGET=nanonote
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+ install -d ${D}${datadir}/applications
+ install -m 0755 ${WORKDIR}/gmu.desktop ${D}${datadir}/applications
+}
+
+SRC_URI[md5sum] = "62653037d2046d992626eaf6d0a365e3"
+SRC_URI[sha256sum] = "9b075a191a8d7fb09164d14ffa489af883b1fae51f579bec95c9c8d8d4758545"