summaryrefslogtreecommitdiffstats
path: root/recipes/git/git-1.7.3.5/git-less-hardlinks.diff
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-01-28 11:05:39 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2011-01-28 11:07:49 +0100
commit3a7b93a388a06eaea766b13b10faaaa661d22c0d (patch)
tree883adadc083fe9ac9028c7c85b8a3616225c83be /recipes/git/git-1.7.3.5/git-less-hardlinks.diff
parent2484007178e3745907d291657fca68d7c6513ca3 (diff)
downloadopenembedded-8564a841a4e9e84cd0ac0128b77e4d05967a8eff.tar.gz
git-1.7.3.5: fix git-less-hardlinks.diff and rename files dir to git-1.7.3.5tested_2011-01-28
* otherwise do_install fails with /bin/sh: -c: line 23: syntax error near unexpected token '||' Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/git/git-1.7.3.5/git-less-hardlinks.diff')
-rw-r--r--recipes/git/git-1.7.3.5/git-less-hardlinks.diff58
1 files changed, 58 insertions, 0 deletions
diff --git a/recipes/git/git-1.7.3.5/git-less-hardlinks.diff b/recipes/git/git-1.7.3.5/git-less-hardlinks.diff
new file mode 100644
index 0000000000..ff192502de
--- /dev/null
+++ b/recipes/git/git-1.7.3.5/git-less-hardlinks.diff
@@ -0,0 +1,58 @@
+From: Koen Kooi <k-kooi@ti.com>
+Subject: Git: don't use hardlink, try softlinks and fall back to plain 'cp'
+
+Using hardlinks confuses packaging an ends up giving us a *copy* of the git binary,
+making the resulting package 54MB big. This brings it down a more managable 4.4M.
+
+This patch isn't complete though:
+
+12cb2bfcde40ce7084ae44af7db88f29 git-cvsserver
+2404a2cd2838be3841eac93de40a644e git
+2404a2cd2838be3841eac93de40a644e git-receive-pack
+2404a2cd2838be3841eac93de40a644e git-upload-archive
+61631194968f67e12abd1f80103a2c68 git-upload-pack
+7b8faebe64076d65934a05cd60bbeb29 git-shell
+
+---
+
+Index: git-1.7.3.5/Makefile
+===================================================================
+--- git-1.7.3.5.orig/Makefile
++++ git-1.7.3.5/Makefile
+@@ -1619,7 +1619,6 @@ builtin/help.s builtin/help.o: EXTRA_CPP
+
+ $(BUILT_INS): git$X
+ $(QUIET_BUILT_IN)$(RM) $@ && \
+- ln git$X $@ 2>/dev/null || \
+ ln -s git$X $@ 2>/dev/null || \
+ cp git$X $@
+
+@@ -1936,7 +1935,6 @@ git-http-push$X: revision.o http.o http-
+
+ $(REMOTE_CURL_ALIASES): $(REMOTE_CURL_PRIMARY)
+ $(QUIET_LNCP)$(RM) $@ && \
+- ln $< $@ 2>/dev/null || \
+ ln -s $< $@ 2>/dev/null || \
+ cp $< $@
+
+@@ -2134,20 +2132,17 @@ endif
+ } && \
+ for p in $(filter $(install_bindir_programs),$(BUILT_INS)); do \
+ $(RM) "$$bindir/$$p" && \
+- ln "$$bindir/git$X" "$$bindir/$$p" 2>/dev/null || \
+ ln -s "git$X" "$$bindir/$$p" 2>/dev/null || \
+ cp "$$bindir/git$X" "$$bindir/$$p" || exit; \
+ done && \
+ for p in $(BUILT_INS); do \
+ $(RM) "$$execdir/$$p" && \
+- ln "$$execdir/git$X" "$$execdir/$$p" 2>/dev/null || \
+ ln -s "git$X" "$$execdir/$$p" 2>/dev/null || \
+ cp "$$execdir/git$X" "$$execdir/$$p" || exit; \
+ done && \
+ remote_curl_aliases="$(REMOTE_CURL_ALIASES)" && \
+ for p in $$remote_curl_aliases; do \
+ $(RM) "$$execdir/$$p" && \
+- ln "$$execdir/git-remote-http$X" "$$execdir/$$p" 2>/dev/null || \
+ ln -s "git-remote-http$X" "$$execdir/$$p" 2>/dev/null || \
+ cp "$$execdir/git-remote-http$X" "$$execdir/$$p" || exit; \
+ done && \