aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gcc/gcc-cross-sdk_svn.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-04-06 12:16:23 -0700
committerKhem Raj <raj.khem@gmail.com>2009-04-06 12:16:23 -0700
commit877fed8078d379d213290b791a8a1282867f5061 (patch)
tree7ff5220fd262e343cc3b70634b41771d14580cdd /recipes/gcc/gcc-cross-sdk_svn.bb
parentfe6822f3e85d5b14586d747c72b4e0395d981ea9 (diff)
downloadopenembedded-877fed8078d379d213290b791a8a1282867f5061.tar.gz
gcc-svn: Add recipe to build bleeding edge gcc.
Diffstat (limited to 'recipes/gcc/gcc-cross-sdk_svn.bb')
-rw-r--r--recipes/gcc/gcc-cross-sdk_svn.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes/gcc/gcc-cross-sdk_svn.bb b/recipes/gcc/gcc-cross-sdk_svn.bb
new file mode 100644
index 0000000000..29ee187785
--- /dev/null
+++ b/recipes/gcc/gcc-cross-sdk_svn.bb
@@ -0,0 +1,14 @@
+PR = "r1"
+
+inherit sdk
+
+require gcc-${PV}.inc
+require gcc-cross-sdk.inc
+require gcc-configure-sdk.inc
+require gcc-package-sdk.inc
+
+DEPENDS += "gmp-native mpfr-native"
+
+EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \
+ --disable-libgomp --disable-libmudflap \
+ --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}"