aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gcc/gcc-4.4.1/gcc-4.2.3-linux-multilib-fix.patch
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2009-08-13 17:30:51 +0100
committerGraeme Gregory <dp@xora.org.uk>2009-08-13 17:30:51 +0100
commit321f298f4b9477ce563eeef68d82a28366788a52 (patch)
tree85d4fbfd46068eaca77311382a6ad99e0191dec9 /recipes/gcc/gcc-4.4.1/gcc-4.2.3-linux-multilib-fix.patch
parent819073c07c1deaac6143bb6eeea96a35a76451b5 (diff)
parent94a9ba7988f0d6586ecaf0b722d6b320cfdf94ae (diff)
downloadopenembedded-321f298f4b9477ce563eeef68d82a28366788a52.tar.gz
Merge branch 'org.openembedded.dev' of /home/dp/openembedded/org.openembedded.dev into xora/angstrom-srcpv
Conflicts: recipes/clutter/clutter-0.9_git.bb recipes/clutter/clutter-gst-0.9_git.bb recipes/efl1/edje_svn.bb recipes/efl1/embryo_svn.bb recipes/efl1/emotion_svn.bb recipes/freesmartphone/cornucopia.inc recipes/freesmartphone/dbus-hlid_git.bb recipes/freesmartphone/frameworkd-devel_git.bb recipes/freesmartphone/frameworkd_git.bb recipes/freesmartphone/fso-abyss_git.bb recipes/freesmartphone/fso-monitord_git.bb recipes/freesmartphone/fso-sounds.bb recipes/freesmartphone/fsod_git.bb recipes/freesmartphone/libframeworkd-glib_git.bb recipes/freesmartphone/libgsm0710mux_git.bb recipes/freesmartphone/vala-dbus-binding-tool-native_git.bb recipes/linux/linux-davinci_git.bb recipes/opencv/opencv-samples_svn.bb recipes/opencv/opencv_svn.bb recipes/u-boot/u-boot_git.bb recipes/uclibc/uclibc_git.bb recipes/uclibc/uclibc_nptl.bb recipes/wmiconfig/wmiconfig_svn.bb
Diffstat (limited to 'recipes/gcc/gcc-4.4.1/gcc-4.2.3-linux-multilib-fix.patch')
-rw-r--r--recipes/gcc/gcc-4.4.1/gcc-4.2.3-linux-multilib-fix.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/gcc/gcc-4.4.1/gcc-4.2.3-linux-multilib-fix.patch b/recipes/gcc/gcc-4.4.1/gcc-4.2.3-linux-multilib-fix.patch
new file mode 100644
index 0000000000..81522a8f57
--- /dev/null
+++ b/recipes/gcc/gcc-4.4.1/gcc-4.2.3-linux-multilib-fix.patch
@@ -0,0 +1,23 @@
+Change gcc build : Enable m4 and m4-nofpu (needed for kernel) for sh4-gnu-linux
+
+Signed-off-by: Carl Shaw <carl.shaw@st.com>
+
+Index: gcc/gcc/config.gcc
+===================================================================
+--- gcc.orig/gcc/config.gcc 2008-07-18 10:37:54.000000000 +0100
++++ gcc/gcc/config.gcc 2008-07-18 11:00:42.000000000 +0100
+@@ -2097,11 +2097,12 @@
+ if test x${sh_multilibs} = x ; then
+ case ${target} in
+ sh64-superh-linux* | \
+- sh[1234]*) sh_multilibs=${sh_cpu_target} ;;
+ sh64* | sh5*) sh_multilibs=m5-32media,m5-32media-nofpu,m5-compact,m5-compact-nofpu,m5-64media,m5-64media-nofpu ;;
+- sh-superh-*) sh_multilibs=m4,m4-single,m4-single-only,m4-nofpu ;;
++ sh-superh-* | \
++ sh4-*-linux*) sh_multilibs=m4,m4-nofpu ;;
+ sh*-*-linux*) sh_multilibs=m1,m3e,m4 ;;
+ sh*-*-netbsd*) sh_multilibs=m3,m3e,m4 ;;
++ sh[1234]*) sh_multilibs=${sh_cpu_target} ;;
+ *) sh_multilibs=m1,m2,m2e,m4,m4-single,m4-single-only,m2a,m2a-single ;;
+ esac
+ if test x$with_fp = xno; then