aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gcc/gcc-4.3.4/debian/libssp-gnu.dpatch
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2009-08-13 17:30:51 +0100
committerGraeme Gregory <dp@xora.org.uk>2009-08-13 17:30:51 +0100
commit321f298f4b9477ce563eeef68d82a28366788a52 (patch)
tree85d4fbfd46068eaca77311382a6ad99e0191dec9 /recipes/gcc/gcc-4.3.4/debian/libssp-gnu.dpatch
parent819073c07c1deaac6143bb6eeea96a35a76451b5 (diff)
parent94a9ba7988f0d6586ecaf0b722d6b320cfdf94ae (diff)
downloadopenembedded-321f298f4b9477ce563eeef68d82a28366788a52.tar.gz
Merge branch 'org.openembedded.dev' of /home/dp/openembedded/org.openembedded.dev into xora/angstrom-srcpv
Conflicts: recipes/clutter/clutter-0.9_git.bb recipes/clutter/clutter-gst-0.9_git.bb recipes/efl1/edje_svn.bb recipes/efl1/embryo_svn.bb recipes/efl1/emotion_svn.bb recipes/freesmartphone/cornucopia.inc recipes/freesmartphone/dbus-hlid_git.bb recipes/freesmartphone/frameworkd-devel_git.bb recipes/freesmartphone/frameworkd_git.bb recipes/freesmartphone/fso-abyss_git.bb recipes/freesmartphone/fso-monitord_git.bb recipes/freesmartphone/fso-sounds.bb recipes/freesmartphone/fsod_git.bb recipes/freesmartphone/libframeworkd-glib_git.bb recipes/freesmartphone/libgsm0710mux_git.bb recipes/freesmartphone/vala-dbus-binding-tool-native_git.bb recipes/linux/linux-davinci_git.bb recipes/opencv/opencv-samples_svn.bb recipes/opencv/opencv_svn.bb recipes/u-boot/u-boot_git.bb recipes/uclibc/uclibc_git.bb recipes/uclibc/uclibc_nptl.bb recipes/wmiconfig/wmiconfig_svn.bb
Diffstat (limited to 'recipes/gcc/gcc-4.3.4/debian/libssp-gnu.dpatch')
-rw-r--r--recipes/gcc/gcc-4.3.4/debian/libssp-gnu.dpatch52
1 files changed, 52 insertions, 0 deletions
diff --git a/recipes/gcc/gcc-4.3.4/debian/libssp-gnu.dpatch b/recipes/gcc/gcc-4.3.4/debian/libssp-gnu.dpatch
new file mode 100644
index 0000000000..a0c6acd9fc
--- /dev/null
+++ b/recipes/gcc/gcc-4.3.4/debian/libssp-gnu.dpatch
@@ -0,0 +1,52 @@
+#! /bin/sh -e
+
+# DP: GNU/k*BSD support
+# Author: Aurelien Jarno <aurel32@debian.org>
+# Status: Submitted: http://gcc.gnu.org/ml/gcc-patches/2007-04/msg01962.html
+
+dir=
+if [ $# -eq 3 -a "$2" = '-d' ]; then
+ pdir="-d $3"
+ dir="$3/"
+elif [ $# -ne 1 ]; then
+ echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+ exit 1
+fi
+case "$1" in
+ -patch)
+ patch $pdir -f --no-backup-if-mismatch -p1 < $0
+ ;;
+ -unpatch)
+ patch $pdir -f --no-backup-if-mismatch -R -p1 < $0
+ ;;
+ *)
+ echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+ exit 1
+esac
+exit 0
+
+# append the patch here and adjust the -p? flag in the patch calls.
+
+--- src.orig/gcc/configure 2008-03-01 15:51:06 +0100
++++ src/gcc/configure 2008-03-01 16:02:24 +0100
+@@ -17110,7 +17110,7 @@
+ else
+ gcc_cv_libc_provides_ssp=no
+ case "$target" in
+- *-*-linux*)
++ *-*-*-gnu*)
+ if test x$host != x$target || test "x$TARGET_SYSTEM_ROOT" != x; then
+ if test "x$with_sysroot" = x; then
+ glibc_header_dir="${exec_prefix}/${target_noncanonical}/sys-include"
+--- src.orig/gcc/configure.ac 2008-02-01 19:55:55 +0100
++++ src/gcc/configure.ac 2008-03-01 16:02:06 +0100
+@@ -3379,7 +3379,7 @@
+ gcc_cv_libc_provides_ssp,
+ [gcc_cv_libc_provides_ssp=no
+ case "$target" in
+- *-*-linux*)
++ *-*-*-gnu*)
+ if test x$host != x$target || test "x$TARGET_SYSTEM_ROOT" != x; then
+ if test "x$with_sysroot" = x; then
+ glibc_header_dir="${exec_prefix}/${target_noncanonical}/sys-include"
+