aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fvwm/fvwm_2.5.26.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/fvwm/fvwm_2.5.26.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/fvwm/fvwm_2.5.26.bb')
-rw-r--r--recipes/fvwm/fvwm_2.5.26.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes/fvwm/fvwm_2.5.26.bb b/recipes/fvwm/fvwm_2.5.26.bb
new file mode 100644
index 0000000000..10677aea6a
--- /dev/null
+++ b/recipes/fvwm/fvwm_2.5.26.bb
@@ -0,0 +1,46 @@
+SECTION = "x11/wm"
+DESCRIPTION = "FVWM Window Manager"
+LICENSE = "GPL"
+DEPENDS = "virtual/libx11 libxext libxfixes libxpm xrandr xft libxml2 zlib libice libxau libxcb libxcursor libxdmcp libxrender libpng librsvg fontconfig libstroke"
+
+SRC_URI="ftp://ftp.fvwm.org/pub/fvwm/version-2/${P}.tar.bz2 \
+ file://oe-configure.ac.patch;patch=1 \
+ file://upstream-configure.ac.patch;patch=1 \
+ file://acinclude.m4.patch;patch=1 \
+ "
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-xinerama --disable-bidi --disable-perllib \
+ --disable-gtk --without-gnome --without-imlib \
+ --disable-freetypetest --disable-fontconfigtest --disable-xfttest \
+ --disable-imlibtest --disable-sm \
+ "
+
+PACKAGES =+ "${PN}-perl"
+
+FILES_${PN}-dbg += " \
+ ${libexecdir}/${PN}/${PV}/.debug \
+ ${bindir}/${PN}-bug \
+"
+
+FILES_${PN}-dev += "${bindir}/${PN}-config"
+
+FILES_${PN}-perl = " \
+ ${bindir}/${PN}-convert-2.4 \
+ ${bindir}/${PN}-convert-2.6 \
+ ${bindir}/${PN}-menu* \
+ ${bindir}/${PN}-perllib \
+ ${libexecdir}/${PN}/${PV}/FvwmPerl \
+ ${libexecdir}/${PN}/${PV}/FvwmCommand.pm \
+ ${libexecdir}/${PN}/${PV}/FvwmConsoleC.pl \
+ ${libexecdir}/${PN}/${PV}/FvwmDebug \
+ ${libexecdir}/${PN}/${PV}/FvwmGtkDebug \
+ ${libexecdir}/${PN}/${PV}/FvwmTabs \
+ ${libexecdir}/${PN}/${PV}/FvwmWindowMenu \
+ ${datadir}/${PN}/FvwmScript-ComExample \
+ ${datadir}/${PN}/FvwmScript-Setup95 \
+ ${datadir}/${PN}/fvwm-script-setup95.pl \
+ ${datadir}/${PN}/fvwm-script-ComExample.pl \
+"
+