aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freesmartphone
diff options
context:
space:
mode:
authorSimon Busch <morphis@gravedo.de>2011-06-17 23:04:10 +0200
committerSimon Busch <morphis@gravedo.de>2011-06-17 23:06:49 +0200
commitbf8ca146ba8c4d7e2dddc65ac7d9dcc1d41a0f81 (patch)
tree402d59cab9b3ec000fcb88c76f6011e4a7d59134 /recipes/freesmartphone
parent33b9aeeafe54a5b6eb43a80dfad3151acc79595d (diff)
downloadopenembedded-bf8ca146ba8c4d7e2dddc65ac7d9dcc1d41a0f81.tar.gz
libfso-qt-embedded: add initial recipe for the embedded version
Signed-off-by: Simon Busch <morphis@gravedo.de>
Diffstat (limited to 'recipes/freesmartphone')
-rw-r--r--recipes/freesmartphone/libfso-qt-embedded_git.bb6
-rw-r--r--recipes/freesmartphone/libfso-qt.inc17
2 files changed, 23 insertions, 0 deletions
diff --git a/recipes/freesmartphone/libfso-qt-embedded_git.bb b/recipes/freesmartphone/libfso-qt-embedded_git.bb
new file mode 100644
index 0000000000..647f4396b2
--- /dev/null
+++ b/recipes/freesmartphone/libfso-qt-embedded_git.bb
@@ -0,0 +1,6 @@
+require libfso-qt.inc
+
+PR = "${INC_PR}.0"
+
+DEPENDS = "qt4-embedded"
+EXTRA_OECONF_append = "--enable-qt-embedded"
diff --git a/recipes/freesmartphone/libfso-qt.inc b/recipes/freesmartphone/libfso-qt.inc
new file mode 100644
index 0000000000..ea48d1086a
--- /dev/null
+++ b/recipes/freesmartphone/libfso-qt.inc
@@ -0,0 +1,17 @@
+DESCRIPTION = "Qt-based DBus bindings for freesmartphone.org"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fad9b3332be894bab9bc501572864b29"
+SECTION = "devel"
+DEPENDS = "fso-specs qfsodbusxml2cpp-native"
+SRCREV = "c932d8b87d0be0c3caba10a1cfa4a6108adac14d"
+PV = "2011.06.01.1+gitr${SRCPV}"
+INC_PR = "r0"
+
+inherit autotools pkgconfig
+
+SRC_URI = "${FREESMARTPHONE_GIT}/libfso-qt.git;protocol=git;branch=master"
+S = "${WORKDIR}/git"
+
+do_configure_prepend() {
+ sed -i -e s#FSO_SPECS_DIR="#FSO_SPECS_DIR="${STAGING_DIR_HOST}/#g ${S}/configure.ac
+}