aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freesmartphone
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-04-11 21:31:11 +0200
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-04-11 21:31:50 +0200
commit3c109747dee974b2076aa8dd5bb25194aaec6201 (patch)
tree4ebcdcf821cec493c921a5bb04b2834b94b6a845 /recipes/freesmartphone
parent8c242916f8e887dde80e39acc7ab6d322447c839 (diff)
downloadopenembedded-3c109747dee974b2076aa8dd5bb25194aaec6201.tar.gz
fsogsmd: new recipe
use cornucopia.inc
Diffstat (limited to 'recipes/freesmartphone')
-rw-r--r--recipes/freesmartphone/cornucopia.inc15
-rw-r--r--recipes/freesmartphone/fsodeviced_git.bb15
-rw-r--r--recipes/freesmartphone/fsogsmd_git.bb2
-rw-r--r--recipes/freesmartphone/libfsoframework_git.bb16
4 files changed, 20 insertions, 28 deletions
diff --git a/recipes/freesmartphone/cornucopia.inc b/recipes/freesmartphone/cornucopia.inc
new file mode 100644
index 0000000000..c3bf018369
--- /dev/null
+++ b/recipes/freesmartphone/cornucopia.inc
@@ -0,0 +1,15 @@
+DESCRIPTION = "The freesmartphone.org API reference implementation (FSO 2.0)"
+AUTHOR = "Team FSO"
+LICENSE = "LGPL"
+SECTION = "devel"
+DEPENDS = "vala-native glib-2.0 dbus dbus-glib"
+PV = "0.0.0.0+gitr${SRCREV}"
+
+SRC_URI = "${FREESMARTPHONE_GIT}/cornucopia;protocol=git;branch=master"
+S = "${WORKDIR}/git/${PN}"
+
+inherit autotools_stage pkgconfig vala
+
+FILES_${PN} += "${sysconfdir} ${datadir}"
+# ship vapi files
+FILES_${PN}-dev += "${datadir}/vala"
diff --git a/recipes/freesmartphone/fsodeviced_git.bb b/recipes/freesmartphone/fsodeviced_git.bb
index 4cb61c7c29..cb3e1586db 100644
--- a/recipes/freesmartphone/fsodeviced_git.bb
+++ b/recipes/freesmartphone/fsodeviced_git.bb
@@ -1,13 +1,2 @@
-DESCRIPTION = "Reference implementation of the org.freesmartphone.Device.* APIs"
-SECTION = "console/network"
-DEPENDS = "libfsoframework"
-LICENSE = "GPL"
-PV = "0.0.0.0+gitr${SRCREV}"
-PR = "r0"
-
-SRC_URI = "\
- ${FREESMARTPHONE_GIT}/cornucopia;protocol=git;branch=master \
-"
-S = "${WORKDIR}/git/fsodeviced"
-
-inherit autotools fso-plugin vala
+require cornucopia.inc
+inherit fso-plugin
diff --git a/recipes/freesmartphone/fsogsmd_git.bb b/recipes/freesmartphone/fsogsmd_git.bb
new file mode 100644
index 0000000000..cb3e1586db
--- /dev/null
+++ b/recipes/freesmartphone/fsogsmd_git.bb
@@ -0,0 +1,2 @@
+require cornucopia.inc
+inherit fso-plugin
diff --git a/recipes/freesmartphone/libfsoframework_git.bb b/recipes/freesmartphone/libfsoframework_git.bb
index 7b03e17041..2fb01bfeb2 100644
--- a/recipes/freesmartphone/libfsoframework_git.bb
+++ b/recipes/freesmartphone/libfsoframework_git.bb
@@ -1,17 +1,3 @@
+require cornucopia.inc
DESCRIPTION = "freesmartphone.org support library"
-LICENSE = "GPL"
-SECTION = "devel"
-DEPENDS = "vala-native glib-2.0 dbus dbus-glib"
-PV = "0.0.0.0+gitr${SRCREV}"
-PR = "r0"
-SRC_URI = "\
- ${FREESMARTPHONE_GIT}/cornucopia;protocol=git;branch=master \
-"
-S = "${WORKDIR}/git/libfsoframework"
-
-inherit autotools_stage pkgconfig
-
-FILES_${PN} += "${sysconfdir} ${datadir}"
-# ship vapi files
-FILES_${PN}-dev += "${datadir}/vala"