aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freesmartphone/zhone_git.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/freesmartphone/zhone_git.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/freesmartphone/zhone_git.bb')
-rw-r--r--recipes/freesmartphone/zhone_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/freesmartphone/zhone_git.bb b/recipes/freesmartphone/zhone_git.bb
new file mode 100644
index 0000000000..0fcc25c5f6
--- /dev/null
+++ b/recipes/freesmartphone/zhone_git.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "A phone UI based on the freesmartphone.org framework"
+LICENSE = "GPL"
+SECTION = "x11"
+DEPENDS = "edje-native python-pyrex-native python-cython-native"
+PV = "0.0.2+gitr${SRCREV}"
+PR = "r12"
+
+SRC_URI = "${FREESMARTPHONE_GIT}/zhone.git;protocol=git;branch=master \
+ file://80zhone"
+S = "${WORKDIR}/git"
+
+inherit distutils
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/X11/Xsession.d/
+ install -m 0755 ${WORKDIR}/80zhone ${D}${sysconfdir}/X11/Xsession.d/
+}
+
+FILES_${PN} += "${datadir} ${sysconfdir}"
+
+RDEPENDS = "\
+ task-python-efl \
+ python-logging \
+ python-textutils \
+ python-dbus \
+ python-pycairo \
+"