aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freesmartphone/fso-specs_git.bb
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-08-06 23:51:34 +0200
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-08-07 02:49:56 +0200
commit8aaba52bea14032340a37959af4a57047cb03c1b (patch)
treea8e45a14240e95aa7058c8f88476448f831a274f /recipes/freesmartphone/fso-specs_git.bb
parentc579f58d519f6e2e58a3b5acc52fc3d9cd953c3d (diff)
downloadopenembedded-8aaba52bea14032340a37959af4a57047cb03c1b.tar.gz
freesmartphone: catch up with milestone5.5 and SHR/import
Diffstat (limited to 'recipes/freesmartphone/fso-specs_git.bb')
-rw-r--r--recipes/freesmartphone/fso-specs_git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/freesmartphone/fso-specs_git.bb b/recipes/freesmartphone/fso-specs_git.bb
new file mode 100644
index 0000000000..b346fb54cb
--- /dev/null
+++ b/recipes/freesmartphone/fso-specs_git.bb
@@ -0,0 +1,21 @@
+DESCRIPTIONS = "API Specification for freesmartphone.org"
+AUTHOR = "Michael 'Mickey' Lauer"
+HOMEPAGE = "http://docs.freesmartphone.org"
+LICENSE = "BSD"
+SECTION = "devel/specifications"
+PV = "0.0.1-gitr${SRCREV}"
+PR = "r2"
+
+SRC_URI = "${FREESMARTPHONE_GIT}/specs.git;protocol=git;branch=master"
+S = "${WORKDIR}/git"
+
+do_compile() {
+ make xml
+}
+
+do_stage() {
+ install -d "${STAGING_DATADIR}/fso-specs"
+ install -m 0644 xml/* "${STAGING_DATADIR}/fso-specs"
+}
+
+FILE_${PN}-dev += "${datadir}/fso-specs"