aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freerdp
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2011-02-28 19:57:24 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2011-03-12 19:16:41 +0000
commit751599197284b031788e482a5b632ac7eda22a02 (patch)
tree8a1dd9668ae3ab981193fc15993b807973182cd2 /recipes/freerdp
parent7afa5f9172525535a8b9da3d6efd578938e44461 (diff)
downloadopenembedded-751599197284b031788e482a5b632ac7eda22a02.tar.gz
freerdp: workaround gcc linking bug forcing -lpthread
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes/freerdp')
-rw-r--r--recipes/freerdp/freerdp.inc7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes/freerdp/freerdp.inc b/recipes/freerdp/freerdp.inc
index 0690d6e9ec..10ce13cc8e 100644
--- a/recipes/freerdp/freerdp.inc
+++ b/recipes/freerdp/freerdp.inc
@@ -8,10 +8,15 @@ RDEPENDS_${PN} += "xprop"
SECTION = "x11/network"
LICENSE = "Apache-2.0"
-INC_PR = "r6"
+INC_PR = "r7"
inherit pkgconfig autotools
+do_configure_prepend() {
+ # workaround gcc linking bug
+ find ${S} -name 'Makefile.am' | xargs -n 1 sed 's,-pthread,-lpthread -D_REENTRANT,g' -i
+}
+
do_install_append() {
rm ${D}${libdir}/freerdp/*.a ${D}${libdir}/freerdp/*.la
}