aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fprobe/fprobe-ulog_1.1.bb
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-03-05 17:13:31 +0300
committerRoman I Khimov <khimov@altell.ru>2010-03-23 20:44:29 +0300
commit7e85836d47d82789a714e5e9e036af15c38ee08b (patch)
tree4f6719edc39367c3ae82b201fb7ffc5ada03115c /recipes/fprobe/fprobe-ulog_1.1.bb
parent58b2dab3bd0253a164ee350382462f279555b7d1 (diff)
downloadopenembedded-7e85836d47d82789a714e5e9e036af15c38ee08b.tar.gz
fprobe-ulog: new recipe
Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/fprobe/fprobe-ulog_1.1.bb')
-rw-r--r--recipes/fprobe/fprobe-ulog_1.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/fprobe/fprobe-ulog_1.1.bb b/recipes/fprobe/fprobe-ulog_1.1.bb
new file mode 100644
index 0000000000..8d082f23e0
--- /dev/null
+++ b/recipes/fprobe/fprobe-ulog_1.1.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "NetFlow probe (libipulog version)"
+SECTION = "network"
+LICENSE = "GPL"
+
+SRC_URI = " \
+ ${SOURCEFORGE_MIRROR}/fprobe/fprobe-ulog/1.1/fprobe-ulog-${PV}.tar.bz2;name=tar \
+ file://init.d \
+ file://default \
+ "
+SRC_URI[tar.md5sum] = "cdb2e4edc47e8a3d5479eeabfb979ebc"
+SRC_URI[tar.sha256sum] = "53b9ccbca4469dfb0e9da91f9f0789dbf732f2adac9de18842e3c210b445f2ad"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "fprobe-ulog"
+
+do_install_append() {
+ ln -s fprobe-ulog ${D}/usr/sbin/fprobe
+ install -d ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/init.d ${D}/${sysconfdir}/init.d/fprobe-ulog
+ install -d ${D}/${sysconfdir}/default
+ install -m 0644 ${WORKDIR}/default ${D}/${sysconfdir}/default/fprobe-ulog
+}