aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ekiga/ptlib_2.6.1.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-04-23 15:59:21 +0200
committerKoen Kooi <koen@openembedded.org>2009-04-23 15:59:21 +0200
commit7209ba7dd74286db6a13e67e28dbe16c740a0d02 (patch)
tree685458cf8e651efce7c6b39490fb9be0625d6b76 /recipes/ekiga/ptlib_2.6.1.bb
parenta292887f0a0534d65336fac3131325742256cbfd (diff)
downloadopenembedded-7209ba7dd74286db6a13e67e28dbe16c740a0d02.tar.gz
ekiga: update to 3.2.0
opal: update to 3.6.1, fix QA ptlib: update to 2.6.1
Diffstat (limited to 'recipes/ekiga/ptlib_2.6.1.bb')
-rw-r--r--recipes/ekiga/ptlib_2.6.1.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/ekiga/ptlib_2.6.1.bb b/recipes/ekiga/ptlib_2.6.1.bb
new file mode 100644
index 0000000000..93a3bd8c96
--- /dev/null
+++ b/recipes/ekiga/ptlib_2.6.1.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Portable Tools Libary"
+LICENSE = "MPL"
+
+inherit gnome
+
+DEPENDS += "libgsm openldap openssl expat virtual/libsdl alsa-lib"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/opalvoip/ptlib-${PV}.tar.bz2"
+
+do_configure() {
+ libtoolize --force
+ gnu-configize
+ oe_runconf
+}
+
+do_compile_append() {
+ sed -i -e s:${STAGING_DIR_TARGET}::g \
+ -e s:/${TARGET_SYS}::g \
+ ptlib.pc
+}
+
+FILES_${PN} += "${libdir}/ptlib-${PV}/*/*/*.so"
+
+do_stage() {
+ autotools_stage_all
+}
+
+
+
+