aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/eglibc/cross-localedef-native_2.12.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-12-13 13:48:16 -0800
committerKhem Raj <raj.khem@gmail.com>2010-12-14 12:09:08 -0800
commit4e6b1bfe289ad346cbd84926a43ad0f93760930d (patch)
tree6aca4f22c736339a0238a25ccfe25608d5ecf475 /recipes/eglibc/cross-localedef-native_2.12.bb
parentc63e599a33bbb8fb389b603309dbdcc0915b13b0 (diff)
downloadopenembedded-4e6b1bfe289ad346cbd84926a43ad0f93760930d.tar.gz
eglibc/glibc: Use/add cross-localedef to generate locales
* Add recipe for cross-localedef-native * Consolidate eglibc/glibc to share common contructs in bbclass * Move common code in eglibc to eglibc.inc * By default use cross-locaedef to generate locales now instead of qemu Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/eglibc/cross-localedef-native_2.12.bb')
-rw-r--r--recipes/eglibc/cross-localedef-native_2.12.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/eglibc/cross-localedef-native_2.12.bb b/recipes/eglibc/cross-localedef-native_2.12.bb
new file mode 100644
index 0000000000..6c26799788
--- /dev/null
+++ b/recipes/eglibc/cross-localedef-native_2.12.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "Cross locale generation tool for eglibc"
+HOMEPAGE = "http://www.eglibc.org/home"
+SECTION = "libs"
+PRIORITY = "required"
+LICENSE = "LGPL"
+
+inherit native
+inherit autotools
+
+PR = "r1"
+SRCREV="12230"
+EGLIBC_BRANCH="eglibc-2_12"
+SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};proto=http "
+S = "${WORKDIR}/${EGLIBC_BRANCH}/localedef"
+
+do_unpack_append() {
+ bb.build.exec_func('do_move_ports', d)
+}
+
+do_move_ports() {
+ if test -d ${WORKDIR}/${EGLIBC_BRANCH}/ports ; then
+ rm -rf ${S}../libc/ports
+ mv ${WORKDIR}/${EGLIBC_BRANCH}/ports ${S}/../libc/
+ fi
+}
+
+EXTRA_OECONF = "--with-glibc=${WORKDIR}/${EGLIBC_BRANCH}/libc"
+
+do_configure () {
+ ./configure ${EXTRA_OECONF}
+}
+
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/localedef ${D}${bindir}/cross-localedef
+}