aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/efl1
diff options
context:
space:
mode:
authorKlaus Kurzmann <mok@fluxnetz.de>2009-12-02 19:57:02 +0100
committerKlaus Kurzmann <mok@fluxnetz.de>2009-12-02 19:57:02 +0100
commite2815b22622d1a05f4bf888f45839c5ef002243e (patch)
tree0ce57246dc786e497de1fc692269ee2d47ecae72 /recipes/efl1
parent18f33cdd3824e23335e357e66c78c698c80cd60f (diff)
parentd7b29de841de569381ae1af8ef7ba522c32f7329 (diff)
downloadopenembedded-e2815b22622d1a05f4bf888f45839c5ef002243e.tar.gz
Merge remote branch 'origin/org.openembedded.dev' into srcpv
Conflicts: recipes/freesmartphone/fso-apm_git.bb recipes/linux/linux-davinci_git.bb recipes/shr/shr-settings_git.bb Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de>
Diffstat (limited to 'recipes/efl1')
-rw-r--r--recipes/efl1/eina/gnu_source.patch12
-rw-r--r--recipes/efl1/eina_svn.bb4
-rw-r--r--recipes/efl1/libeweather_svn.bb44
3 files changed, 59 insertions, 1 deletions
diff --git a/recipes/efl1/eina/gnu_source.patch b/recipes/efl1/eina/gnu_source.patch
new file mode 100644
index 0000000000..8af08ebb82
--- /dev/null
+++ b/recipes/efl1/eina/gnu_source.patch
@@ -0,0 +1,12 @@
+Index: eina/configure.ac
+===================================================================
+--- eina.orig/configure.ac 2009-11-26 15:58:28.784112802 +0100
++++ eina/configure.ac 2009-11-26 15:59:34.524939842 +0100
+@@ -273,6 +273,7 @@
+ AC_C_INLINE
+ AC_C___ATTRIBUTE__
+ AC_PROG_CC_STDC
++AC_GNU_SOURCE
+
+ EINA_CPPFLAGS=""
+ case "$host_os" in
diff --git a/recipes/efl1/eina_svn.bb b/recipes/efl1/eina_svn.bb
index 4871cd3ce9..a871721e7c 100644
--- a/recipes/efl1/eina_svn.bb
+++ b/recipes/efl1/eina_svn.bb
@@ -1,10 +1,12 @@
DESCRIPTION = "Eina is the Enlightenment data library"
LICENSE = "LGPL"
PV = "0.0.2.060+svnr${SRCPV}"
-PR = "r0"
+PR = "r1"
inherit efl
+SRC_URI += "file://gnu_source.patch;patch=1"
+
# Some upgrade path tweaking
AUTO_LIBNAME_PKGS = ""
diff --git a/recipes/efl1/libeweather_svn.bb b/recipes/efl1/libeweather_svn.bb
new file mode 100644
index 0000000000..6668f08278
--- /dev/null
+++ b/recipes/efl1/libeweather_svn.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "EFL-based weather widget library"
+LICENSE = "LGPL"
+DEPENDS = "ecore edje"
+PV = "0.0.0+svnr${SRCPV}"
+PR = "r0"
+
+inherit efl
+
+EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
+
+SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk/PROTO;module=eweather;proto=http"
+S = "${WORKDIR}/eweather"
+
+RSUGGESTS_${PN} = "elementary-tests"
+
+do_compile_append() {
+ sed -i -e s:${STAGING_DIR_TARGET}::g \
+ -e s:/${TARGET_SYS}::g \
+ eweather.pc
+}
+
+PACKAGES += "${PN}-plugins"
+
+FILES_${PN}-themes = "\
+ ${datadir} \
+"
+
+FILES_${PN}-plugins = "\
+ ${libdir}/eweather/plugins/*.so \
+"
+
+FILES_${PN}-dbg += "\
+ ${libdir}/eweather/plugins/.debug \
+"
+
+FILES_${PN}-dev += "\
+ ${libdir}/eweather/plugins/*.a \
+ ${libdir}/eweather/plugins/*.la \
+"
+
+RRECOMMENDS_${PN} = "\
+ ${PN}-themes \
+ ${PN}-plugins \
+"