aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/efl1/epsilon_svn.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/efl1/epsilon_svn.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/efl1/epsilon_svn.bb')
-rw-r--r--recipes/efl1/epsilon_svn.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/efl1/epsilon_svn.bb b/recipes/efl1/epsilon_svn.bb
new file mode 100644
index 0000000000..ad928eb693
--- /dev/null
+++ b/recipes/efl1/epsilon_svn.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Epsilon is a flexible and powerful image thumbnailing library \
+that is compliant with the freedesktop.org Thumbnail Managing Standard."
+LICENSE = "MIT BSD"
+# can also depend on xine for movie thumbnails
+DEPENDS = "libpng evas ecore edje perl-native"
+PV = "0.3.0.012+svnr${SRCREV}"
+PR = "r4"
+
+inherit efl
+
+# a gstreamer thumbnailer would be nice now that we have emotion using gstreamer as well
+EXTRA_OECONF = "--disable-xine"
+
+# package the thumb daemon seperately
+PACKAGES =+ "${PN}-thumbd"
+FILES_${PN}-thumbd = "${bindir}/epsilon ${bindir}/epsilon_thumbd"
+RRECOMMENDS_${PN} = "${PN}-thumbd"
+
+FILES_${PN}-dev += "${libdir}/${PN}/*/*.a ${libdir}/${PN}/*/*.la"
+FILES_${PN}-dbg += "${libdir}/${PN}/plugins/.debug/*.so"
+