aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/e17
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-04-04 17:50:37 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2011-04-04 19:35:39 +0200
commitb7753cc9685c4595e1919759edb58eeaa1bfbc8a (patch)
tree21cd37def03acbc9bd15b0f59b205b5b930f6ecd /recipes/e17
parent73e10e3b082a79eee9943199bfdad14cb233e282 (diff)
downloadopenembedded-b7753cc9685c4595e1919759edb58eeaa1bfbc8a.tar.gz
elmdentica: fix build after azy changes from r58286
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/e17')
-rw-r--r--recipes/e17/elmdentica/0001-elmdentica-adapt-to-azy-changes-r58286.patch39
-rw-r--r--recipes/e17/elmdentica_svn.bb4
2 files changed, 42 insertions, 1 deletions
diff --git a/recipes/e17/elmdentica/0001-elmdentica-adapt-to-azy-changes-r58286.patch b/recipes/e17/elmdentica/0001-elmdentica-adapt-to-azy-changes-r58286.patch
new file mode 100644
index 0000000000..040e0a7a76
--- /dev/null
+++ b/recipes/e17/elmdentica/0001-elmdentica-adapt-to-azy-changes-r58286.patch
@@ -0,0 +1,39 @@
+From 1a032dae3a9877287157003ec7e8986b76f2a644 Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Mon, 4 Apr 2011 17:14:30 +0200
+Subject: [PATCH] elmdentica: adapt to azy changes r58286
+
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+---
+ src/Makefile.am | 2 +-
+ src/statusnet.c | 1 +
+ 2 files changed, 2 insertions(+), 1 deletions(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index e729027..2bd1622 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -19,7 +19,7 @@ AM_LDFLAGS = @PTHREAD_LIBS@ \
+ `curl-config --libs` \
+ @ELEMENTARY_LIBS@
+
+-BUILT_SOURCES = statusnet_Common.h statusnet_Common.c
++BUILT_SOURCES = statusnet_Common.h statusnet_Common.c statusnet_Common_Azy.h statusnet_Common_Azy.c
+ CLEANFILES = $(BUILT_SOURCES) .sources-ts
+ $(BUILT_SOURCES): .sources-ts
+ .sources-ts: statusnet.azy
+diff --git a/src/statusnet.c b/src/statusnet.c
+index b1c4775..44e8d5f 100644
+--- a/src/statusnet.c
++++ b/src/statusnet.c
+@@ -35,6 +35,7 @@
+
+ #include <Azy.h>
+ #include "statusnet_Common.h"
++#include "statusnet_Common_Azy.h"
+
+ #include <sqlite3.h>
+
+--
+1.7.4.1
+
diff --git a/recipes/e17/elmdentica_svn.bb b/recipes/e17/elmdentica_svn.bb
index 013a7ded01..a2e3f3546f 100644
--- a/recipes/e17/elmdentica_svn.bb
+++ b/recipes/e17/elmdentica_svn.bb
@@ -6,7 +6,9 @@ HOMEPAGE = "http://elmdentica.googlecode.com"
AUTHOR = "seabra"
inherit e gettext
-SRC_URI = "${E_SVN}/trunk;module=${SRCNAME};proto=http;scmdata=keep"
+SRC_URI = "${E_SVN}/trunk;module=${SRCNAME};proto=http;scmdata=keep \
+ file://0001-elmdentica-adapt-to-azy-changes-r58286.patch;minrev=58286"
+
S = "${WORKDIR}/${SRCNAME}"
EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"