aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dtc
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-04-15 18:49:32 -0700
committerTom Rini <tom_rini@mentor.com>2011-04-15 18:50:15 -0700
commit45f4be3e05918b4b3072301382ec52e14ad2f6a4 (patch)
treeea030bf8291babfe0312f078f23a47d25e67fe8d /recipes/dtc
parentca45b6dbad81d1ffb983c348a229aa7fa676ad2b (diff)
downloadopenembedded-45f4be3e05918b4b3072301382ec52e14ad2f6a4.tar.gz
dtc: Switch to BBCLASSEXTEND and INC_PR
Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/dtc')
-rw-r--r--recipes/dtc/dtc-native.inc10
-rw-r--r--recipes/dtc/dtc-native_1.2.0.bb11
-rw-r--r--recipes/dtc/dtc-native_20070216.bb9
-rw-r--r--recipes/dtc/dtc-native_git.bb2
-rw-r--r--recipes/dtc/dtc.inc10
-rw-r--r--recipes/dtc/dtc_1.2.0.bb2
-rw-r--r--recipes/dtc/dtc_20070216.bb2
-rw-r--r--recipes/dtc/dtc_git.bb11
-rw-r--r--recipes/dtc/dtc_git.inc9
9 files changed, 21 insertions, 45 deletions
diff --git a/recipes/dtc/dtc-native.inc b/recipes/dtc/dtc-native.inc
deleted file mode 100644
index 4503bc74d1..0000000000
--- a/recipes/dtc/dtc-native.inc
+++ /dev/null
@@ -1,10 +0,0 @@
-require dtc.inc
-
-inherit native
-
-NATIVE_INSTALL_WORKS = "1"
-
-do_install() {
- install -d ${D}${bindir}
- install -m 755 dtc ${D}${bindir}/
-}
diff --git a/recipes/dtc/dtc-native_1.2.0.bb b/recipes/dtc/dtc-native_1.2.0.bb
deleted file mode 100644
index ca636e6130..0000000000
--- a/recipes/dtc/dtc-native_1.2.0.bb
+++ /dev/null
@@ -1,11 +0,0 @@
-require dtc-native.inc
-
-DEFAULT_PREFERENCE = "1"
-
-SRC_URI = "http://www.jdl.com/software/dtc-v${PV}.tgz"
-
-S = "${WORKDIR}/dtc-v${PV}"
-
-
-SRC_URI[md5sum] = "0f1841de79abbff57691adc31d5f3525"
-SRC_URI[sha256sum] = "dabbe5a77ffcffd906333589a75013e4b40113238b6b09f7f2ad280ba3bb6a1c"
diff --git a/recipes/dtc/dtc-native_20070216.bb b/recipes/dtc/dtc-native_20070216.bb
deleted file mode 100644
index d0bef20299..0000000000
--- a/recipes/dtc/dtc-native_20070216.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-require dtc-native.inc
-
-SRC_URI = "http://www.jdl.com/pub/software/dtc-${PV}.tgz"
-
-S = "${WORKDIR}/dtc"
-
-
-SRC_URI[md5sum] = "8762121262ead127171c4fce40ccc289"
-SRC_URI[sha256sum] = "dd687b4f691bf9970f53ca2c84d8481b9f82d857de347375d29bacf648b8da71"
diff --git a/recipes/dtc/dtc-native_git.bb b/recipes/dtc/dtc-native_git.bb
deleted file mode 100644
index 2d6f09217f..0000000000
--- a/recipes/dtc/dtc-native_git.bb
+++ /dev/null
@@ -1,2 +0,0 @@
-require dtc-native.inc
-require dtc_git.inc
diff --git a/recipes/dtc/dtc.inc b/recipes/dtc/dtc.inc
index 427fcd433a..a7607ed526 100644
--- a/recipes/dtc/dtc.inc
+++ b/recipes/dtc/dtc.inc
@@ -3,11 +3,19 @@ SECTION = "bootloader"
PRIORITY = "optional"
LICENSE = "GPL"
DEPENDS = "flex-native bison-native"
+BBCLASSEXTEND = "native"
+INC_PR = "r2"
inherit autotools
do_install() {
install -m 0755 -d ${D}${bindir}
- install -m 755 dtc ${D}${bindir}/dtc
+ install -m 0755 dtc ${D}${bindir}/dtc
+ install -m 0755 -d ${D}${libdir}
+ install -m 0644 libfdt/libfdt.a ${D}${libdir}/libfdt.a
+ install -m 0755 -d ${D}${includedir}
+ install -m 0644 libfdt/fdt.h ${D}${includedir}/fdt.h
+ install -m 0644 libfdt/libfdt.h ${D}${includedir}/libfdt.h
}
+NATIVE_INSTALL_WORKS = "1"
diff --git a/recipes/dtc/dtc_1.2.0.bb b/recipes/dtc/dtc_1.2.0.bb
index 8db35c2578..be50aeebdc 100644
--- a/recipes/dtc/dtc_1.2.0.bb
+++ b/recipes/dtc/dtc_1.2.0.bb
@@ -1,6 +1,6 @@
require dtc.inc
-PR = "r0"
+PR = "${INC_PR}.0"
DEFAULT_PREFERENCE = "1"
diff --git a/recipes/dtc/dtc_20070216.bb b/recipes/dtc/dtc_20070216.bb
index 573ad8f3d0..a772d70bc3 100644
--- a/recipes/dtc/dtc_20070216.bb
+++ b/recipes/dtc/dtc_20070216.bb
@@ -1,6 +1,6 @@
require dtc.inc
-PR = "r1"
+PR = "${INC_PR}.0"
SRC_URI = "http://www.jdl.com/pub/software/dtc-${PV}.tgz"
diff --git a/recipes/dtc/dtc_git.bb b/recipes/dtc/dtc_git.bb
index a17a39d527..92740f0ac9 100644
--- a/recipes/dtc/dtc_git.bb
+++ b/recipes/dtc/dtc_git.bb
@@ -1,2 +1,11 @@
require dtc.inc
-require dtc_git.inc
+
+SRC_URI = "git://git.jdl.com/software/dtc.git;protocol=git"
+SRCREV = "73dca9ae0b9abe6924ba640164ecce9f8df69c5a"
+PV = "1.2.0"
+PR = "${INC_PR}.0"
+PR_append = "+gitr${SRCREV}"
+
+DEFAULT_PREFERENCE = "-1"
+
+S = "${WORKDIR}/git"
diff --git a/recipes/dtc/dtc_git.inc b/recipes/dtc/dtc_git.inc
deleted file mode 100644
index ded44f6c8c..0000000000
--- a/recipes/dtc/dtc_git.inc
+++ /dev/null
@@ -1,9 +0,0 @@
-SRC_URI = "git://www.jdl.com/software/dtc.git;protocol=git"
-SRCREV = "73dca9ae0b9abe6924ba640164ecce9f8df69c5a"
-PV = "1.2.0"
-PR = "r1"
-PR_append = "+gitr${SRCREV}"
-
-DEFAULT_PREFERENCE = "-1"
-
-S = "${WORKDIR}/git"