aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dsniff
diff options
context:
space:
mode:
authorGraham Gower <graham.gower@gmail.com>2010-10-10 20:25:10 +0000
committerKhem Raj <raj.khem@gmail.com>2010-10-13 21:30:27 -0700
commit6b2da63ff97143cac33f0fdd188577539787b977 (patch)
tree6412e0068b264b30b39dd7f6681434933591385b /recipes/dsniff
parentbe5bc791c9808a4d39fedb4a8c4140a054f95cf9 (diff)
downloadopenembedded-6b2da63ff97143cac33f0fdd188577539787b977.tar.gz
dsniff_2.3.bb: fix buildability.
This almost 10 year old software is beginning to suffer bitrot. Libnids now uses glib, and openssl structs have moved headers. Signed-off-by: Graham Gower <graham.gower@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/dsniff')
-rw-r--r--recipes/dsniff/dsniff-2.3/openssl-includes.patch11
-rw-r--r--recipes/dsniff/dsniff_2.3.bb7
2 files changed, 15 insertions, 3 deletions
diff --git a/recipes/dsniff/dsniff-2.3/openssl-includes.patch b/recipes/dsniff/dsniff-2.3/openssl-includes.patch
new file mode 100644
index 0000000000..033fc5c37a
--- /dev/null
+++ b/recipes/dsniff/dsniff-2.3/openssl-includes.patch
@@ -0,0 +1,11 @@
+--- dsniff-2.3/sshcrypto.c.orig 2010-10-11 16:38:25.000000000 +1030
++++ dsniff-2.3/sshcrypto.c 2010-10-11 16:38:30.000000000 +1030
+@@ -14,6 +14,8 @@
+
+ #include <sys/types.h>
+ #include <openssl/ssl.h>
++#include <openssl/blowfish.h>
++#include <openssl/des.h>
+
+ #include <err.h>
+ #include <stdio.h>
diff --git a/recipes/dsniff/dsniff_2.3.bb b/recipes/dsniff/dsniff_2.3.bb
index 03ef527d09..51f2113056 100644
--- a/recipes/dsniff/dsniff_2.3.bb
+++ b/recipes/dsniff/dsniff_2.3.bb
@@ -3,16 +3,17 @@ SECTION = "console/network"
HOMEPAGE = "http://www.monkey.org/~dugsong/dsniff/"
AUTHOR = "Dug Song <dugsong@monkey.org>"
LICENSE = "BSD"
-PR = "r2"
+PR = "r3"
# There is a significant API change beween 1.0.2a of libnet and
# 1.1.x, dsniff will only work with the older and there is no
# updated version of dnsniff.
-DEPENDS = "virtual/db libpcap libnet-1.0 libnids openssl"
+DEPENDS = "virtual/db libpcap libnet-1.0 libnids openssl glib-2.0"
SRC_URI = "\
http://www.monkey.org/~dugsong/dsniff/dsniff-${PV}.tar.gz \
file://configure.patch \
+ file://openssl-includes.patch \
"
inherit autotools
@@ -27,7 +28,7 @@ EXTRA_OECONF = "\
EXTRA_OEMAKE = "'install_prefix=${D}'"
CFLAGS =+ "-I${S}/missing"
-LDFLAGS += "-lresolv"
+LDFLAGS += "-lresolv -lglib-2.0 -lgthread-2.0 -lrt -pthread"
SRC_URI[md5sum] = "183e336a45e38013f3af840bddec44b4"
SRC_URI[sha256sum] = "82e492455486e655c315f027d393dbeb49ad930804acccdc51b30d57e1294ff5"