aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/directfb/fusionsound_1.1.0+git20070709.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/directfb/fusionsound_1.1.0+git20070709.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/directfb/fusionsound_1.1.0+git20070709.bb')
-rw-r--r--recipes/directfb/fusionsound_1.1.0+git20070709.bb59
1 files changed, 59 insertions, 0 deletions
diff --git a/recipes/directfb/fusionsound_1.1.0+git20070709.bb b/recipes/directfb/fusionsound_1.1.0+git20070709.bb
new file mode 100644
index 0000000000..dda1de5333
--- /dev/null
+++ b/recipes/directfb/fusionsound_1.1.0+git20070709.bb
@@ -0,0 +1,59 @@
+DESCRIPTION = "FusionSound for DirectFB"
+DEPENDS = "directfb"
+SECTION = "libs"
+LICENSE = "LGPL"
+PR = "r2"
+
+SRC_URI = "git://git.directfb.org/git/directfb/core/FusionSound;protocol=git;tag=0b2162b570c8314fd1240b08d6ab4a8d074ccf37 \
+ file://fix-pkgconfig-cflags.patch;patch=1 \
+ file://use_limits_h.patch;patch=1 \
+"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+CFLAGS_append += " -I${STAGING_INCDIR}/directfb -I${STAGING_INCDIR}/directfb-internal"
+
+#Below are some of the configure options
+EXTRA_OECONF = " \
+ --disable-ieee-floats \
+ --disable-precision \
+ --enable-linear-filter \
+ --disable-dithering \
+ --enable-debug \
+ --enable-examples \
+ --enable-module \
+ --disable-timidity \
+ --disable-wave \
+ --enable-vorbis \
+ --enable-tremor \
+ --disable-mad \
+ --disable-cdda \
+ --disable-playlist \
+ "
+
+do_configure_append() {
+ find ${S} -type f | xargs sed -i 's:I/usr/include:I${STAGING_INCDIR}:g'
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
+
+FILES_fusionsound-dbg_append = " ${libdir}/directfb-1.1-0/*/*/.debug/*.so \
+ ${libdir}/directfb-1.1-0/*/.debug/*.so \
+ "
+
+FILES_fusionsound-dev_append = " ${libdir}/directfb-1.1-0/interfaces/*/*.la \
+ ${libdir}/directfb-1.1-0/snddrivers/*.la \
+ "
+
+FILES_fusionsound_append = " ${libdir}/directfb-1.1-0/interfaces/*/*.so \
+ ${libdir}/directfb-1.1-0/snddrivers/*.so \
+ "
+