aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/devmem2
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2011-01-18 08:23:33 -0700
committerChris Larson <chris_larson@mentor.com>2011-01-18 08:23:33 -0700
commitad5ce1595eca7b2ddd8b4e5a6ee6e67ff5ed80f0 (patch)
treef435d57f243bdc7b4a9ddc4eb6e427eb284b58a1 /recipes/devmem2
parent23e2a9d9a201013834b8e20de60defa5320628bc (diff)
downloadopenembedded-ad5ce1595eca7b2ddd8b4e5a6ee6e67ff5ed80f0.tar.gz
devmem2: enable strict alignment
Signed-off-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'recipes/devmem2')
-rw-r--r--recipes/devmem2/devmem2.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes/devmem2/devmem2.bb b/recipes/devmem2/devmem2.bb
index 0baa7f0955..2d1e67b627 100644
--- a/recipes/devmem2/devmem2.bb
+++ b/recipes/devmem2/devmem2.bb
@@ -1,11 +1,13 @@
DESCRIPTION = "Simple program to read/write from/to any location in memory."
LICENSE = "GPLv2"
-PR = "r6"
+PR = "r7"
SRC_URI = "http://www.lartmaker.nl/lartware/port/devmem2.c \
file://devmem2-fixups-2.patch;apply=yes;striplevel=0"
S = "${WORKDIR}"
+CFLAGS += "-DFORCE_STRICT_ALIGNMENT"
+
do_compile() {
${CC} -o devmem2 devmem2.c ${CFLAGS} ${LDFLAGS}
}