aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cup/cup-native_0.10k.bb
diff options
context:
space:
mode:
authorRobert Schuster <robertschuster@fsfe.org>2009-09-18 13:42:32 +0200
committerRobert Schuster <robertschuster@fsfe.org>2009-09-18 13:42:32 +0200
commitd9fef0c7c9c064337223f847af28b6da4a180ced (patch)
treecd496b78261c03e7ab1dbdfbe28113d38c7d088a /recipes/cup/cup-native_0.10k.bb
parente815e80bdf71c0c4cf0469d0b362be6dfe37e075 (diff)
downloadopenembedded-d9fef0c7c9c064337223f847af28b6da4a180ced.tar.gz
cup 0.10k: New recipe (from Jalimo SVN).
cup-native 0.10k: Dito.
Diffstat (limited to 'recipes/cup/cup-native_0.10k.bb')
-rw-r--r--recipes/cup/cup-native_0.10k.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/cup/cup-native_0.10k.bb b/recipes/cup/cup-native_0.10k.bb
new file mode 100644
index 0000000000..2eb325fe1a
--- /dev/null
+++ b/recipes/cup/cup-native_0.10k.bb
@@ -0,0 +1,24 @@
+require cup_${PV}.bb
+
+inherit java-native
+
+DEPENDS += "virtual/java-native"
+RDEPENDS = ""
+
+do_configure() {
+ sed -i \
+ -e "s|OE_STAGING_BINDIR|${STAGING_BINDIR_NATIVE}|" \
+ -e "s|OE_STAGING_DATADIR_JAVA|${STAGING_DATADIR_JAVA_NATIVE}|" \
+ -e "s|OE_CUP_JAR|${BP}.jar|" \
+ ${WORKDIR}/cup
+}
+
+do_install_append() {
+ :
+}
+
+do_stage_append() {
+ install -d ${STAGING_BINDIR}
+ install -m 0755 ${WORKDIR}/cup ${STAGING_BINDIR}
+}
+