aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/corosync/corosync_1.2.0.bb
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-03-22 22:37:58 +0300
committerRoman I Khimov <khimov@altell.ru>2010-03-29 13:28:01 +0400
commit5595df3516313bc8b3ffde448ce0c6abb086a1fc (patch)
tree81942483e734cef1321d2c3afd6cfa9bc3a88298 /recipes/corosync/corosync_1.2.0.bb
parentc5497549b9caf94be40a938b6dfcfb664ce5f186 (diff)
downloadopenembedded-5595df3516313bc8b3ffde448ce0c6abb086a1fc.tar.gz
corosync: add new recipe
The Corosync Cluster Engine is an OSI Certified implementation of a complete cluster engine. Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/corosync/corosync_1.2.0.bb')
-rw-r--r--recipes/corosync/corosync_1.2.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes/corosync/corosync_1.2.0.bb b/recipes/corosync/corosync_1.2.0.bb
new file mode 100644
index 0000000000..758f45577d
--- /dev/null
+++ b/recipes/corosync/corosync_1.2.0.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "OSI Certified implementation of a complete cluster engine"
+LICENSE = "BSD"
+
+SRC_URI = " \
+ ftp://ftp@corosync.org/downloads/corosync-${PV}/corosync-${PV}.tar.gz;name=tar \
+ file://fix-lcrso-linkage.patch;patch=1 \
+ file://init \
+ file://corosync.conf \
+ file://volatiles \
+ "
+SRC_URI[tar.md5sum] = "789bea831a97977e56900477c3022cc1"
+SRC_URI[tar.sha256sum] = "3cee3be9f747c7031da9eafdffa5e3009513f4ac93ce021a49574e3de1fd93f0"
+
+inherit autotools_stage update-rc.d
+
+INITSCRIPT_NAME = "corosync-daemon"
+
+EXTRA_OECONF = "--disable-nss"
+
+FILES_${PN}-dbg += "${libexecdir}/lcrso/.debug"
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/init.d
+ install -d ${D}${sysconfdir}/default/volatiles
+ install -m 0755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/corosync-daemon
+ install -m 0644 ${WORKDIR}/corosync.conf ${D}/${sysconfdir}/corosync/corosync.conf.example
+ install -m 0644 ${WORKDIR}/volatiles ${D}${sysconfdir}/default/volatiles/05_corosync
+}
+
+pkg_postinst_${PN} () {
+ set -e
+ grep haclient /etc/group || addgroup haclient
+ grep hacluster /etc/passwd || adduser --disabled-password --home=/var/lib/heartbeat --ingroup haclient -g "HA cluster" hacluster
+ /etc/init.d/populate-volatile.sh update
+}