aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/coreutils/coreutils_6.0.bb
diff options
context:
space:
mode:
authorSebastian Spaeth <Sebastian@SSpaeth.de>2009-12-17 15:04:26 +0100
committerSebastian Spaeth <Sebastian@SSpaeth.de>2009-12-17 15:04:26 +0100
commitb7e9814253f4b8f61e68d9aa7f518c1404cf417f (patch)
treed30408cd8f13b8d3c57437e41b514573ca1a4eae /recipes/coreutils/coreutils_6.0.bb
parente3df24d64a48aff19aa9960dd9308a071b243b09 (diff)
parent727b276ed3d414662f19ec66e80f7b3dc029bca5 (diff)
downloadopenembedded-b7e9814253f4b8f61e68d9aa7f518c1404cf417f.tar.gz
Merge commit 'origin/org.openembedded.dev' into shr/merge
Diffstat (limited to 'recipes/coreutils/coreutils_6.0.bb')
-rw-r--r--recipes/coreutils/coreutils_6.0.bb86
1 files changed, 3 insertions, 83 deletions
diff --git a/recipes/coreutils/coreutils_6.0.bb b/recipes/coreutils/coreutils_6.0.bb
index d0d082bc63..009dad34cf 100644
--- a/recipes/coreutils/coreutils_6.0.bb
+++ b/recipes/coreutils/coreutils_6.0.bb
@@ -1,89 +1,9 @@
-require coreutils.inc
+require coreutils-${PV}.inc
+require coreutils-target.inc
PR = "r3"
-SRC_URI = "\
- ftp://alpha.gnu.org/gnu/coreutils/coreutils-${PV}.tar.bz2 \
+SRC_URI += "\
file://man.patch;patch=1 \
file://oe-old-tools.patch;patch=1 \
- file://futimens.patch;patch=1 \
- file://coreutils-install-use-STRIP.patch;patch=1 \
- file://onceonly.m4 \
"
-
-# [ gets a special treatment and is not included in this
-bindir_progs = "basename cksum comm csplit cut df dir dircolors dirname du \
- env expand expr factor fmt fold groups head hostid id install \
- join link logname md5sum mkfifo nice nl nohup od paste pathchk \
- pinky pr printenv printf ptx readlink seq sha1sum shred sort \
- split stat sum tac tail tee test tr tsort tty unexpand uniq \
- unlink users vdir wc who whoami yes \
- "
-
-# hostname gets a special treatment and is not included in this
-base_bindir_progs = "cat chgrp chmod chown cp date dd echo false kill \
- ln ls mkdir mknod mv pwd rm rmdir sleep stty sync touch \
- true uname \
- "
-
-sbindir_progs= "chroot"
-
-do_configure_prepend() {
- install -m 0644 ${WORKDIR}/onceonly.m4 ${S}/m4
-}
-
-do_install () {
- autotools_do_install
-
- # Renaming the utilities that should go in /usr/bin
- for i in ${bindir_progs}; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${PN}; done
-
- # Renaming and moving the utilities that should go in /bin (FHS)
- install -d ${D}${base_bindir}
- for i in ${base_bindir_progs}; do mv ${D}${bindir}/$i ${D}${base_bindir}/$i.${PN}; done
-
- # Renaming and moving the utilities that should go in /usr/sbin (FHS)
- install -d ${D}${sbindir}
- for i in ${sbindir_progs}; do mv ${D}${bindir}/$i ${D}${sbindir}/$i.${PN}; done
-
- # [ requires special handling because [.coreutils will cause the sed stuff
- # in update-alternatives to fail, therefore use lbracket - the name used
- # for the actual source file.
- mv ${D}${bindir}/[ ${D}${bindir}/lbracket.${PN}
- # hostname and uptime separated. busybox's versions are preferred
- mv ${D}${bindir}/hostname ${D}${base_bindir}/hostname.${PN}
- mv ${D}${bindir}/uptime ${D}${bindir}/uptime.${PN}
-
-}
-
-pkg_postinst_${PN} () {
- # The utilities in /usr/bin
- for i in ${bindir_progs}; do update-alternatives --install ${bindir}/$i $i $i.${PN} 100; done
-
- # The utilities in /bin
- for i in ${base_bindir_progs}; do update-alternatives --install ${base_bindir}/$i $i $i.${PN} 100; done
-
- # The utilities in /usr/sbin
- for i in ${sbindir_progs}; do update-alternatives --install ${sbindir}/$i $i $i.${PN} 100; done
-
- # Special cases. uptime and hostname is broken, prefer busybox's version. [ needs to be treated separately.
- update-alternatives --install ${bindir}/uptime uptime uptime.${PN} 10
- update-alternatives --install ${base_bindir}/hostname hostname hostname.${PN} 10
- update-alternatives --install '${bindir}/[' '[' 'lbracket.${PN}' 100
-}
-
-pkg_prerm_${PN} () {
- # The utilities in /usr/bin
- for i in ${bindir_progs}; do update-alternatives --remove $i $i.${PN}; done
-
- # The utilities in /bin
- for i in ${base_bindir_progs}; do update-alternatives --remove $i $i.${PN}; done
-
- # The utilities in /usr/sbin
- for i in ${sbindir_progs}; do update-alternatives --remove $i $i.${PN}; done
-
- # The special cases
- update-alternatives --remove hostname hostname.${PN}
- update-alternatives --remove uptime uptime.${PN}
- update-alternatives --remove '[' 'lbracket.${PN}'
-}