aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cmake/cmake-2.8.2
diff options
context:
space:
mode:
authorDavid Kozub <zub@linux.fjfi.cvut.cz>2010-07-29 08:11:36 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2010-08-19 07:47:44 +0200
commitd0f8c51b166e16aea809cb396ed3b4200266a5e1 (patch)
treec65f315c51f7822ff576fa7fb272e79c5d015dd5 /recipes/cmake/cmake-2.8.2
parent585f3201eb97d4c33204efe72847f78e1841f156 (diff)
downloadopenembedded-d0f8c51b166e16aea809cb396ed3b4200266a5e1.tar.gz
cmake-2.8.2: Add recipe for non-native cmake 2.8.2.
Tested on om-gta02: * builds trivial C and C++ executable * "include(FindPkgConfig)" correctly finds the cmake module * pkg_check_modules correctly invokes pkg-config * ccmake works Also tested on babbage by Eduardo Lima (thanks for help). Unfortunately, useful doc is not packaged. The reason is that the doc is produced by running the built binaries. Changing this would probably require a complex patch of the build process. Luckily, the doc is still contained in the original binaries, so it's accessible on target by e.g. cmake --help-full. Signed-off-by: David Kozub <zub@linux.fjfi.cvut.cz> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/cmake/cmake-2.8.2')
-rw-r--r--recipes/cmake/cmake-2.8.2/dont-run-cross-binaries.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/recipes/cmake/cmake-2.8.2/dont-run-cross-binaries.patch b/recipes/cmake/cmake-2.8.2/dont-run-cross-binaries.patch
new file mode 100644
index 0000000000..4a006f967c
--- /dev/null
+++ b/recipes/cmake/cmake-2.8.2/dont-run-cross-binaries.patch
@@ -0,0 +1,13 @@
+diff -ru cmake-2.8.2.orig/CMakeLists.txt cmake-2.8.2/CMakeLists.txt
+--- cmake-2.8.2.orig/CMakeLists.txt 2010-07-28 00:48:42.000000000 +0200
++++ cmake-2.8.2/CMakeLists.txt 2010-07-28 01:05:17.000000000 +0200
+@@ -518,7 +518,8 @@
+
+ # build the remaining subdirectories
+ ADD_SUBDIRECTORY(Source)
+-ADD_SUBDIRECTORY(Utilities)
++# Come on! Running the cross-binaries on host is not a good idea.
++#ADD_SUBDIRECTORY(Utilities)
+ ADD_SUBDIRECTORY(Tests)
+
+ # add a test