summaryrefslogtreecommitdiffstats
path: root/recipes/clutter/clutter-gtk.inc
diff options
context:
space:
mode:
authorAndreas Mueller <schnitzeltony@gmx.de>2010-09-07 10:07:54 +0200
committerKoen Kooi <koen@openembedded.org>2010-09-07 10:07:54 +0200
commit8d64681eb7e2fa74be5dfd2f5a945f57d61113b9 (patch)
tree8fcba04a1f89f10cd065f2f3b80fc023efaafba5 /recipes/clutter/clutter-gtk.inc
parent2eca1eb59ccb0890e4db078a4af456c9f2d194ad (diff)
downloadopenembedded-8d64681eb7e2fa74be5dfd2f5a945f57d61113b9.tar.gz
clutter: clean builds for clutter 1.0
* all 0.9 recipes (are actually 1.0rc) & files referenced were removed * all 0.8 recipes were renamed to clutter*-0.8 to ensure parallel installation with later versions * clutter-common.inc as container for helpers was created (also from clutter-fpu.inc) * clutter-1.0_1.0.10.bb was renamed to clutter_1.0.10.bb * clutter-gst_1.2.0.bb introduced the first ever buildable in GLES environment without further effords * clutter-gtk_0.10.2.bb is the latest version which supports clutter 1.0.x (later ones complain on configure for clutter 1.2.x) * clutter* examples / tests are build properly and packed in extra packages. For clutter-interactive tests menu entries (graphics) are added / test-conformance-run runs all conformance tests (crashing tests do not abort) Signed-off-by: Andreas Mueller <schnitzeltony@gmx.de> Acked-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/clutter/clutter-gtk.inc')
-rw-r--r--recipes/clutter/clutter-gtk.inc26
1 files changed, 21 insertions, 5 deletions
diff --git a/recipes/clutter/clutter-gtk.inc b/recipes/clutter/clutter-gtk.inc
index d9b01ca00b..6e624c5378 100644
--- a/recipes/clutter/clutter-gtk.inc
+++ b/recipes/clutter/clutter-gtk.inc
@@ -1,11 +1,27 @@
-DESCRIPTION = "Clutter GTK+"
+DESCRIPTION = "Clutter GTK+ integration library"
HOMEPAGE = "http://www.clutter-project.org/"
-LICENSE = "LGPL"
+LICENSE = "LGPLv2.1"
-DEPENDS = "gtk+"
+INC_PR = "r1"
-PACKAGES =+ "${PN}-examples"
-FILES_${PN}-examples = "${bindir}/gtk-clutter-test ${bindir}/gtk-clutter-events ${bindir}/gtk-clutter-multistage"
+DEPENDS = "gtk+ clutter"
+require clutter-common.inc
inherit autotools pkgconfig gtk-doc
+do_configure_prepend() {
+ make_all_execs_installable
+
+ # Align the examples data location
+ for i in $(find ${S}/examples -name *.c) ; do
+ sed -i -e 's:\"redhand.png\":\"${datadir}/${PN}-examples/redhand.png\":g' $i
+ done
+}
+
+do_install_append () {
+ install -m 755 -d ${D}${datadir}/${PN}-examples
+ install -m 755 ${S}/examples/redhand.png ${D}${datadir}/${PN}-examples
+}
+
+PACKAGES =+ "${PN}-examples"
+FILES_${PN}-examples = "${bindir}/* ${datadir}/${PN}-examples"