aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bash
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@buglabs.net>2011-02-18 11:26:48 +0100
committerStefan Schmidt <stefan@buglabs.net>2011-02-18 11:55:36 +0100
commitf94e88e8a49ecae723de61ac5d04b0c3f8139eca (patch)
tree0752a2f7b8a7cb6e221d9077be695372c057059a /recipes/bash
parent2d23c765c66e84f9844b3fad4628f549a448a9ce (diff)
downloadopenembedded-f94e88e8a49ecae723de61ac5d04b0c3f8139eca.tar.gz
bash: Add bash-sh package to switch /bin/sh to /bin/bash
An old change from hrw in the BugLabs repo I forgot to bring over earlier.
Diffstat (limited to 'recipes/bash')
-rw-r--r--recipes/bash/bash.inc13
-rw-r--r--recipes/bash/bash_3.0.bb2
-rw-r--r--recipes/bash/bash_3.2.bb2
3 files changed, 15 insertions, 2 deletions
diff --git a/recipes/bash/bash.inc b/recipes/bash/bash.inc
index 239ddd1921..99c6398cfc 100644
--- a/recipes/bash/bash.inc
+++ b/recipes/bash/bash.inc
@@ -33,3 +33,16 @@ pkg_postinst () {
grep -q "bin/bash" $D${sysconfdir}/shells || echo /bin/bash >> $D${sysconfdir}/shells
grep -q "bin/sh" $D${sysconfdir}/shells || echo /bin/sh >> $D${sysconfdir}/shells
}
+
+PACKAGES += "bash-sh"
+RDEPENDS_bash-sh = "bash"
+
+ALLOW_EMPTY_bash-sh = "1"
+
+pkg_postinst_bash-sh() {
+ cd $D/bin && ln -sf bash sh
+}
+
+pkg_postrm_bash-sh() {
+ ln -sf /bin/busybox /bin/sh
+}
diff --git a/recipes/bash/bash_3.0.bb b/recipes/bash/bash_3.0.bb
index 60e6707f2b..ec0510ed1f 100644
--- a/recipes/bash/bash_3.0.bb
+++ b/recipes/bash/bash_3.0.bb
@@ -1,5 +1,5 @@
require bash.inc
-PR = "r13"
+PR = "r14"
SRC_URI += "\
file://bash-3.0-fixes.patch \
diff --git a/recipes/bash/bash_3.2.bb b/recipes/bash/bash_3.2.bb
index 5a41882249..4758a4f600 100644
--- a/recipes/bash/bash_3.2.bb
+++ b/recipes/bash/bash_3.2.bb
@@ -1,6 +1,6 @@
require bash.inc
-PR = "r11"
+PR = "r12"
SRC_URI += "\
file://builtins.patch \