aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/aceofpenguins/aceofpenguins
diff options
context:
space:
mode:
authorThomas Zimmermann <ml@vdm-design.de>2010-07-26 22:28:04 +0200
committerThomas Zimmermann <ml@vdm-design.de>2010-07-26 22:28:04 +0200
commitf392e7f75ceaebf874b4e5567666661f6199b58c (patch)
treec55b897a537e6f26e8852ea74934f4797b744887 /recipes/aceofpenguins/aceofpenguins
parent87dc166bade8722af4076c8644cac6a0a437826f (diff)
downloadopenembedded-f392e7f75ceaebf874b4e5567666661f6199b58c.tar.gz
aceofpenguins: update to version 1.3
* new game: spider * some fixes * renamed files folder to aceofpenguins Signed-off-by: Thomas Zimmermann <ml@vdm-design.de>
Diffstat (limited to 'recipes/aceofpenguins/aceofpenguins')
-rw-r--r--recipes/aceofpenguins/aceofpenguins/fix-crosscompile.patch13
-rw-r--r--recipes/aceofpenguins/aceofpenguins/gcc4.patch23
2 files changed, 36 insertions, 0 deletions
diff --git a/recipes/aceofpenguins/aceofpenguins/fix-crosscompile.patch b/recipes/aceofpenguins/aceofpenguins/fix-crosscompile.patch
new file mode 100644
index 0000000000..ff3ac0ffa8
--- /dev/null
+++ b/recipes/aceofpenguins/aceofpenguins/fix-crosscompile.patch
@@ -0,0 +1,13 @@
+diff -Nurd ace-1.2/lib/Makefile.am ace-1.2.new//lib/Makefile.am
+--- ace-1.2/lib/Makefile.am 2010-02-18 12:21:30.000000000 +0100
++++ ace-1.2.new//lib/Makefile.am 2010-02-18 12:21:30.000000000 +0100
+@@ -22,7 +22,7 @@
+ ./make-imglib -n cards -i $(srcdir)/png -d images.d $(srcdir)/images.in images.c
+
+ make-imglib : make-imglib.c
+- $(BUILD_CC) $(srcdir)/make-imglib.c -o make-imglib -lpng -lz
++ $(BUILD_CC) $(srcdir)/make-imglib.c -o make-imglib $(BUILD_CFLAGS) $(BUILD_LDFLAGS) -lpng -lz
+
+ text2c : text2c.c
+- $(BUILD_CC) $(srcdir)/text2c.c -o text2c -lpng -lz
++ $(BUILD_CC) $(srcdir)/text2c.c -o text2c $(BUILD_CFLAGS) $(BUILD_LDFLAGS) -lpng -lz
diff --git a/recipes/aceofpenguins/aceofpenguins/gcc4.patch b/recipes/aceofpenguins/aceofpenguins/gcc4.patch
new file mode 100644
index 0000000000..431c44e933
--- /dev/null
+++ b/recipes/aceofpenguins/aceofpenguins/gcc4.patch
@@ -0,0 +1,23 @@
+--- ace-of-penguins-1.2.orig/games/golf.c
++++ ace-of-penguins-1.2/games/golf.c
+@@ -31,7 +31,7 @@
+
+ Stack *deck, *discard, *stacks[7];
+
+-static int table_width, table_height;
++int table_width, table_height;
+
+ int supress_arrows = 0;
+
+--- ace-of-penguins-1.2.orig/games/solitaire.c
++++ ace-of-penguins-1.2/games/solitaire.c
+@@ -337,7 +337,7 @@
+ return something_moved;
+ }
+
+-static void
++void
+ check_for_end_of_game()
+ {
+ while (auto_move());
+