aboutsummaryrefslogtreecommitdiffstats
path: root/pcre
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2004-02-15 00:46:37 +0000
committerMichael Lauer <mickey@vanille-media.de>2004-02-15 00:46:37 +0000
commita1979e24892c35ac93ed77d4b040ab6dcd26c0cf (patch)
tree790166118c3326d05781baf341df3c28dc470fa6 /pcre
parent1ce72146cc121ce319a9b76bcdb2373fb424131a (diff)
downloadopenembedded-a1979e24892c35ac93ed77d4b040ab6dcd26c0cf.tar.gz
add libtomcrypt (cryptographic library)
BKrev: 402ec16dYnIQc2TJnwVZFFNeRuLeOg
Diffstat (limited to 'pcre')
-rw-r--r--pcre/pcre-4.4/lai.patch18
-rw-r--r--pcre/pcre-4.4/rpath.patch22
-rw-r--r--pcre/pcre_4.4.oe38
3 files changed, 78 insertions, 0 deletions
diff --git a/pcre/pcre-4.4/lai.patch b/pcre/pcre-4.4/lai.patch
index e69de29bb2..6170a36771 100644
--- a/pcre/pcre-4.4/lai.patch
+++ b/pcre/pcre-4.4/lai.patch
@@ -0,0 +1,18 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- pcre-4.4/Makefile.in~lai
++++ pcre-4.4/Makefile.in
+@@ -208,8 +208,10 @@
+
+ install: all @ON_WINDOWS@ wininstall
+ @NOT_ON_WINDOWS@ $(mkinstalldirs) $(DESTDIR)$(LIBDIR)
++@NOT_ON_WINDOWS@ if [ ! -e .libs/libpcre.lai ]; then cp libpcre.la .libs/libpcre.lai; fi
+ @NOT_ON_WINDOWS@ echo "$(LIBTOOL) --mode=install $(INSTALL) libpcre.la $(DESTDIR)$(LIBDIR)/libpcre.la"
+ @NOT_ON_WINDOWS@ $(LIBTOOL) --mode=install $(INSTALL) libpcre.la $(DESTDIR)$(LIBDIR)/libpcre.la
++@NOT_ON_WINDOWS@ if [ ! -e .libs/libpcreposix.lai ]; then cp libpcreposix.la .libs/libpcreposix.lai; fi
+ @NOT_ON_WINDOWS@ echo "$(LIBTOOL) --mode=install $(INSTALL) libpcreposix.la $(DESTDIR)$(LIBDIR)/libpcreposix.la"
+ @NOT_ON_WINDOWS@ $(LIBTOOL) --mode=install $(INSTALL) libpcreposix.la $(DESTDIR)$(LIBDIR)/libpcreposix.la
+ @NOT_ON_WINDOWS@ $(LIBTOOL) --finish $(DESTDIR)$(LIBDIR)
diff --git a/pcre/pcre-4.4/rpath.patch b/pcre/pcre-4.4/rpath.patch
index e69de29bb2..29a4413c4b 100644
--- a/pcre/pcre-4.4/rpath.patch
+++ b/pcre/pcre-4.4/rpath.patch
@@ -0,0 +1,22 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- pcre-4.4/Makefile.in~rpath
++++ pcre-4.4/Makefile.in
+@@ -107,12 +107,12 @@
+
+ libpcre.la: $(OBJ)
+ -rm -f libpcre.la
+- $(LINKLIB) -rpath $(LIBDIR) -version-info \
++ $(LINKLIB) -version-info \
+ '$(PCRELIBVERSION)' -o libpcre.la $(LOBJ)
+
+ libpcreposix.la: pcreposix.@OBJEXT@
+ -rm -f libpcreposix.la
+- $(LINKLIB) -rpath $(LIBDIR) libpcre.la -version-info \
++ $(LINKLIB) libpcre.la -version-info \
+ '$(PCREPOSIXLIBVERSION)' -o libpcreposix.la pcreposix.lo
+
+ pcre.@OBJEXT@: $(top_srcdir)/chartables.c $(top_srcdir)/pcre.c \
diff --git a/pcre/pcre_4.4.oe b/pcre/pcre_4.4.oe
index e69de29bb2..8a6e4ce556 100644
--- a/pcre/pcre_4.4.oe
+++ b/pcre/pcre_4.4.oe
@@ -0,0 +1,38 @@
+DEPENDS = virtual/libc
+RDEPENDS = libc6
+DESCRIPTION = Perl-compatible regular expression library. PCRE has its own native \
+API, but a set of "wrapper" functions that are based on the POSIX API \
+are also supplied in the library libpcreposix. Note that this just \
+provides a POSIX calling interface to PCRE; the regular expressions \
+themselves still follow Perl syntax and semantics. The header file for \
+the POSIX-style functions is called pcreposix.h.
+
+
+SRC_URI = ftp://ftp.csx.cam.ac.uk/pub/software/programming/${PN}/${P}.tar.bz2 \
+ file://${FILESDIR}/rpath.patch;patch=1 \
+ file://${FILESDIR}/lai.patch;patch=1
+S = "${WORKDIR}/${P}"
+
+inherit autotools libtool
+
+CFLAGS_append = " -D_REENTRANT"
+EXTRA_OECONF = " --with-link-size=2 --enable-newline-is-lf --with-match-limit=10000000"
+do_compile () {
+ ${BUILD_CC} -DLINK_SIZE=2 -I${S}/include -c dftables.c
+ ${BUILD_CC} dftables.o -o dftables
+ oe_runmake
+}
+
+do_stage () {
+ install -m 0755 .libs/libpcreposix.so.0.0.0 ${STAGING_LIBDIR}/
+ ln -sf libpcreposix.so.0.0.0 ${STAGING_LIBDIR}/libpcreposix.so.0
+ install -m 0755 .libs/libpcre.so.0.0.1 ${STAGING_LIBDIR}/
+ ln -sf libpcre.so.0.0.1 ${STAGING_LIBDIR}/libpcre.so.0
+
+ ln -sf libpcre.so.0.0.1 ${STAGING_LIBDIR}/libpcre.so
+ ln -sf libpcreposix.so.0.0.0 ${STAGING_LIBDIR}/libpcreposix.so
+ install -m 0644 .libs/libpcre.a ${STAGING_LIBDIR}/
+ install -m 0644 .libs/libpcreposix.a ${STAGING_LIBDIR}/
+ install -m 0644 pcre.h ${STAGING_DIR}/target/include/
+ install -m 0644 pcreposix.h ${STAGING_DIR}/target/include/
+}