aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorMichael-Luke Jones <mlj28@cam.ac.uk>2006-09-28 19:01:32 +0000
committerMichael-Luke Jones <mlj28@cam.ac.uk>2006-09-28 19:01:32 +0000
commit025dcf03ba051ac356efbf128868a2283a6d940a (patch)
treea738c6dcf4df1d1ce93dfaddac1ab8d47420dfb7 /packages
parentdfdac86de873437af6abfb18e2bb7586e0d4ce8c (diff)
downloadopenembedded-025dcf03ba051ac356efbf128868a2283a6d940a.tar.gz
ixp4xx-kernel: Add auto-byteswapping patch
ixp4xx-npe: Remove byteswapping behaviour slugos-init: lengthen delay slightly
Diffstat (limited to 'packages')
-rw-r--r--packages/ixp4xx/ixp4xx-npe_2.1.bb16
-rw-r--r--packages/ixp4xx/ixp4xx-npe_2.3.bb16
-rw-r--r--packages/linux/ixp4xx-kernel_2.6.18.bb2
-rw-r--r--packages/slugos-init/files/boot/disk2
-rw-r--r--packages/slugos-init/slugos-init_0.10.bb2
5 files changed, 19 insertions, 19 deletions
diff --git a/packages/ixp4xx/ixp4xx-npe_2.1.bb b/packages/ixp4xx/ixp4xx-npe_2.1.bb
index c06b4c28fb..efeb0cbbba 100644
--- a/packages/ixp4xx/ixp4xx-npe_2.1.bb
+++ b/packages/ixp4xx/ixp4xx-npe_2.1.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "NPE firmware for the IXP4xx line of devices"
MAINTAINER = "Oyvind Repvik <nail@nslu2-linux.org>"
LICENSE = "Intel Public Licence"
-PR = "r5"
+PR = "r6"
DEPENDS = "ixp4xx-npe-native"
SRC_URI = "http://www.intel.com/Please-Read-The-BB-File/IPL_ixp400NpeLibrary-2_1.zip"
@@ -10,14 +10,14 @@ S = ${WORKDIR}/ixp400_xscale_sw/src/npeDl
FILES_${PN} = "${base_libdir}/firmware/NPE-B"
do_compile() {
- if test '${ARCH_BYTE_SEX}' = be
- then
+# if test '${ARCH_BYTE_SEX}' = be
+# then
${STAGING_BINDIR}/IxNpeMicrocode-${PV} -be
- fi
- if test '${ARCH_BYTE_SEX}' = le
- then
- ${STAGING_BINDIR}/IxNpeMicrocode-${PV} -le
- fi
+# fi
+# if test '${ARCH_BYTE_SEX}' = le
+# then
+# ${STAGING_BINDIR}/IxNpeMicrocode-${PV} -le
+# fi
}
do_install() {
diff --git a/packages/ixp4xx/ixp4xx-npe_2.3.bb b/packages/ixp4xx/ixp4xx-npe_2.3.bb
index 9e13c8766b..babb7e1292 100644
--- a/packages/ixp4xx/ixp4xx-npe_2.3.bb
+++ b/packages/ixp4xx/ixp4xx-npe_2.3.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "NPE firmware for the IXP4xx line of devices"
MAINTAINER = "Oyvind Repvik <nail@nslu2-linux.org>"
LICENSE = "Intel Public Licence"
-PR = "r5"
+PR = "r6"
DEPENDS = "ixp4xx-npe-native"
SRC_URI = "http://www.intel.com/Please-Read-The-BB-File/IPL_ixp400NpeLibrary-2_3.zip"
@@ -10,14 +10,14 @@ S = ${WORKDIR}/ixp400_xscale_sw/src/npeDl
FILES_${PN} = "${base_libdir}/firmware/NPE-B"
do_compile() {
- if test '${ARCH_BYTE_SEX}' = be
- then
+# if test '${ARCH_BYTE_SEX}' = be
+# then
${STAGING_BINDIR}/IxNpeMicrocode-${PV} -be
- fi
- if test '${ARCH_BYTE_SEX}' = le
- then
- ${STAGING_BINDIR}/IxNpeMicrocode-${PV} -le
- fi
+# fi
+# if test '${ARCH_BYTE_SEX}' = le
+# then
+# ${STAGING_BINDIR}/IxNpeMicrocode-${PV} -le
+# fi
}
do_install() {
diff --git a/packages/linux/ixp4xx-kernel_2.6.18.bb b/packages/linux/ixp4xx-kernel_2.6.18.bb
index a5f2ff5b8c..bfa1059825 100644
--- a/packages/linux/ixp4xx-kernel_2.6.18.bb
+++ b/packages/linux/ixp4xx-kernel_2.6.18.bb
@@ -6,7 +6,7 @@
# http://trac.nslu2-linux.org/kernel/
#
# The revision that is pulled from SVN is specified below
-IXP4XX_KERNEL_SVN_REV = "435"
+IXP4XX_KERNEL_SVN_REV = "438"
#
# Increment the number below (i.e. the digits after PR) when
# the changes in SVN between revisions include changes in the
diff --git a/packages/slugos-init/files/boot/disk b/packages/slugos-init/files/boot/disk
index 17fb1f3243..ff55baa04c 100644
--- a/packages/slugos-init/files/boot/disk
+++ b/packages/slugos-init/files/boot/disk
@@ -22,7 +22,7 @@ then
echo "boot: loading modules required for disk boot"
loaddiskmods
# waiting for disk (FIXME)
- sleep=5
+ sleep=6
test "$sleep" -gt 0 && sleep "$sleep"
#
# fire the boot
diff --git a/packages/slugos-init/slugos-init_0.10.bb b/packages/slugos-init/slugos-init_0.10.bb
index 7c8d0fa9f5..efd396e84f 100644
--- a/packages/slugos-init/slugos-init_0.10.bb
+++ b/packages/slugos-init/slugos-init_0.10.bb
@@ -4,7 +4,7 @@ PRIORITY = "required"
LICENSE = "GPL"
DEPENDS = "base-files devio"
RDEPENDS = "busybox devio"
-PR = "r70"
+PR = "r71"
SRC_URI = "file://boot/flash \
file://boot/disk \